<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
    <meta charset="utf-8">
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <meta name="google-site-verification" content="nsTES39gUO8mLrF9qhSPlkMQdLw5QxRvXSSdHmmKrfo" />
    <meta name="google-site-verification" content="MIMK9CXINw4NIyotnrw84JZT9oDBm8ia58feoWyMhSk" />
    <link rel="shortcut icon" href="https://ambrosiaforheads.com/wp-content/themes/ambrosiaforheads_v2/favicon.ico">

    <meta http-equiv="X-UA-Compatible" content="IE=edge">

    <link rel="profile" href="https://gmpg.org/xfn/11" />
    <link rel="pingback" href="https://ambrosiaforheads.com/xmlrpc.php" />
    
    <title>Ambrosia For Heads&#039; Top 15 Hip-Hop Albums Of 2019 List</title>
    <link rel="stylesheet" href="https://ambrosiaforheads.com/wp-content/themes/ambrosiaforheads_v2/stylesheets/ie.css">
    
   <script id="Cookiebot" src="https://consent.cookiebot.com/uc.js" data-cbid="e73985d2-1436-4112-96b7-ab69e7ad64c6" type="text/javascript" async></script>
   
    
    <!-- HTML5 shim and Respond.js IE8 support of HTML5 elements and media queries -->
    <!--[if lt IE 9]>
        <script type="text/javascript" data-cookieconsent="necessary" src="https://ambrosiaforheads.com/wp-content/themes/ambrosiaforheads_v2/js/html5shiv.js"></script>
        <script type="text/javascript" data-cookieconsent="necessary" src="https://ambrosiaforheads.com/wp-content/themes/ambrosiaforheads_v2/js/respond.min.js"></script>
    <![endif]-->

	<!-- Google Tag Manager -->
	<script type="text/javascript" data-cookieconsent="necessary">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-KZV522D');</script>
	<!-- End Google Tag Manager -->

	<!-- Global site tag (gtag.js) - Google Analytics -->
	<script type="text/plain" data-cookieconsent="statistics" async src="https://www.googletagmanager.com/gtag/js?id=UA-20430092-1"></script>
	<script>
	  window.dataLayer = window.dataLayer || [];
	  function gtag(){dataLayer.push(arguments);}
	  gtag('js', new Date());
	
	  gtag('config', 'UA-20430092-1');
	</script>

    <script  type="text/plain" data-cookieconsent="necessary">var _sf_startpt=(new Date()).getTime()</script>

    <script type="text/plain" data-cookieconsent="marketing">(function() {
      var _fbq = window._fbq || (window._fbq = []);
      if (!_fbq.loaded) {
        var fbds = document.createElement('script');
        fbds.async = true;
        fbds.src = '//connect.facebook.net/en_US/fbds.js';
        var s = document.getElementsByTagName('script')[0];
        s.parentNode.insertBefore(fbds, s);
        _fbq.loaded = true;
      }
      _fbq.push(['addPixelId', '1524742197780495']);
    })();
    window._fbq = window._fbq || [];
    window._fbq.push(['track', 'PixelInitialized', {}]);
    </script>

    <script type="text/plain" data-cookieconsent="marketing">(function(d, s, id) {
      var js, fjs = d.getElementsByTagName(s)[0];
      if (d.getElementById(id)) return;
      js = d.createElement(s); js.id = id;
      js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.5";
      fjs.parentNode.insertBefore(js, fjs);
    }(document, 'script', 'facebook-jssdk'));</script>

    <meta property="fb:pages" content="172178912816534" />
	<meta property="test" content="content" />
    
    <!--
<script> 
  var PREBID_TIMEOUT = 1200;
	
	var adUnits = [];
	var prebidIsMobile = false;
	if (window.innerWidth < 992) prebidIsMobile = true;
	
	
	if (prebidIsMobile) {

		adUnits.push(
            {
				code: 'div-gpt-ad-1477792058192-0', //33196227/AFH_Mobile_ROS_Leaderboard
				sizes: [[320, 50]],
				bids: [{
					bidder: 'aol',
					params: {
						network: '10730.1',
						placement: '4477745'
					}
				}]
			}, {
				code: 'div-gpt-ad-1477792125489-0', //33196227/AFH_Mobile_ROS_Instream
				sizes: [[300, 250]],
				bids: [{
					bidder: 'aol',
					params: {
						network: '10730.1',
						placement: '4477745'
					}
				}]
            }
        );

	} else {
		adUnits.push({
			code: 'div-gpt-ad-1477791617272-0', //33196227/AFH_Article_LR1
			sizes: [[300, 250]],
			bids: [{
				bidder: 'aol',
				params: {
					network: '10730.1',
					placement: '4477736'
				}
			}]
		}, {
			code: 'div-gpt-ad-1477791585092-0', //33196227/AFH_Article_Instream_Leaderboard
			sizes: [[728, 90]],
			bids: [{
				bidder: 'aol',
				params: {
					network: '10730.1',
					placement: '4477734'
				}
			}]
		}, {
			code: 'div-gpt-ad-1477791514607-0', //33196227/AFH_Article_Leaderboard
			sizes: [[728, 90], [970,250]],
			bids: [{
				bidder: 'aol',
				params: {
					network: '10730.1',
					placement: '4477737'
				}
			}]
		}, {
			code: 'div-gpt-ad-1477860397051-0', //33196227/AFH_Article_LR2 
			sizes: [[300, 250], [300,600]],
			bids: [{
				bidder: 'aol',
				params: {
					network: '10730.1',
					placement: '4477738'
				}
			}]
		});
	}
    
    var pbjs = pbjs || {};
    pbjs.que = pbjs.que || [];

  </script>

  <script type="text/javascript" src="//acdn.adnxs.com/prebid/not-for-prod/prebid.js" async></script>
  <script>
    var googletag = googletag || {};
    googletag.cmd = googletag.cmd || [];
    googletag.cmd.push(function() {
        googletag.pubads().disableInitialLoad();
    });

    pbjs.que.push(function() {
		pbjs.setPriceGranularity("dense");
        pbjs.addAdUnits(adUnits);
        pbjs.requestBids({
            bidsBackHandler: sendAdserverRequest
        });
    });

    function sendAdserverRequest() {
        if (pbjs.adserverRequestSent) return;
        pbjs.adserverRequestSent = true;
        googletag.cmd.push(function() {
            pbjs.que.push(function() {
                pbjs.setTargetingForGPTAsync();
                googletag.pubads().refresh();
            });
        });
    }

    setTimeout(function() {
        sendAdserverRequest();
    }, PREBID_TIMEOUT);

  </script>

  <script>
    (function () {
        var gads = document.createElement('script');
        gads.async = true;
        gads.type = 'text/javascript';
        var useSSL = 'https:' == document.location.protocol;
        gads.src = (useSSL ? 'https:' : 'http:') +
                '//www.googletagservices.com/tag/js/gpt.js';
        var node = document.getElementsByTagName('script')[0];
        node.parentNode.insertBefore(gads, node);
    })();
  </script>

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
		<script>
		  var googletag = googletag || {};
		  googletag.cmd = googletag.cmd || [];
		</script>

		<script>
		  googletag.cmd.push(function() {

	googletag.pubads().setTargeting("env", ["staging"]);

		googletag.defineSlot('/33196227/AFH_Article_Instream_Leaderboard', [728, 90], 'div-gpt-ad-1477791585092-0').addService(googletag.pubads());
			googletag.pubads().enableSingleRequest();
			googletag.enableServices();
		  });

		  googletag.cmd.push(function() {
			googletag.defineSlot('/33196227/AFH_Article_LR1', [[300, 250], [336, 280]], 'div-gpt-ad-1477791617272-0').addService(googletag.pubads());
			googletag.pubads().enableSingleRequest();
			googletag.enableServices();
		  });
		  
		  googletag.cmd.push(function() {
			window.sidebarRefresh = googletag.defineSlot('/33196227/AFH_Article_LR2', [[300, 250], [300, 600]], 'div-gpt-ad-1477860397051-0').addService(googletag.pubads());
			googletag.pubads().enableSingleRequest();
			googletag.enableServices();
		  });

		  googletag.cmd.push(function() {
            var leaderboardTopSizeMapping = googletag.sizeMapping()
                                                    .addSize([0, 0], [])
                                                    .addSize([728, 0], [[728, 90]])
                                                    .addSize([970, 0], [ [970, 250], [728, 90] ])
                                                    .build();

			googletag.defineSlot('/33196227/AFH_Article_Leaderboard', [[728, 90], [970, 250]], 'div-gpt-ad-1477791514607-0').defineSizeMapping(leaderboardTopSizeMapping).addService(googletag.pubads());
			googletag.pubads().enableSingleRequest();
			googletag.enableServices();
		  });

        googletag.cmd.push(function() {
			window.mobileRefresh = googletag.defineSlot('/33196227/AFH_Mobile_ROS_Leaderboard', [320, 50], 'div-gpt-ad-1477792058192-0').addService(googletag.pubads());
			googletag.pubads().enableSingleRequest();
			googletag.enableServices();
		  });
		  
		  googletag.cmd.push(function() {

googletag.defineSlot('/33196227/AFH_Mobile_ROS_Instream', [300, 250], 'div-gpt-ad-1477792125489-0').addService(googletag.pubads());
			
//googletag.defineSlot('/33196227/AFH_Article_LR1', [300, 250], 'div-gpt-ad-1533756944194-0').addService(googletag.pubads());

googletag.pubads().enableSingleRequest();
            googletag.enableServices();
          });

</script>
-->    
    <!-- Mirror Header scripts -->
	
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>

<!-- SORTABLE-->
<script async="async" src="//tags-cdn.deployads.com/a/ambrosiaforheads.com.js"></script>

<script type='text/javascript'>
	
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];

/* SORTABLE */
window.deployads = window.deployads || []; 

var gptAdSlots = [];
var mapping = [];

googletag.cmd.push(function() {
		
	//AFH Above Article Leaderboard Flex
	mapping[0] = googletag.sizeMapping().        
        addSize([1020, 300],[[970, 250], [728, 90]]).
		addSize([768, 200], [728, 90]).
		addSize([0, 0],[[320, 50], [300, 50]]).build();
	
	// AFH Above Box
	mapping[1] = googletag.sizeMapping().
        addSize([768, 200], [[300, 250], [300, 600]]).
        addSize([0, 0], [300, 250]).build();
	
	// AFH Below Article Box Flex
	mapping[2] = googletag.sizeMapping().
        addSize([0, 0], [300, 250]).build();
	
	// AFH Below Article Leaderboard
	mapping[3] = googletag.sizeMapping().
        addSize([768, 200], [728, 90]).
        addSize([0, 0], []).build();
			
	window.width = window.innerWidth || document.documentElement.clientWidth || document.body.clientWidth;
	if (window.width > 767) { var type = '-desktop'; } else { var type = '-mobile'; }
	
			
		//AFH Above Article Leaderboard Flex
		googletag.defineSlot('/284704979/ambrosiaforheads/AFH_Above_Article_Leaderboard_Flex', [728, 90], 'div-gpt-ad-1540251912042-0'+type).defineSizeMapping(mapping[0]).addService(googletag.pubads()).setCollapseEmptyDiv(true);  
		
		if (window.width > 767) {
			// AFH Above Box
			googletag.defineSlot('/284704979/ambrosiaforheads/AFH_Above_Box', [[300, 250],[300, 600]], 'div-gpt-ad-1540251912042-1'+type).defineSizeMapping(mapping[1]).addService(googletag.pubads()).setCollapseEmptyDiv(true); 
		}
		
		// AFH Below Article Box Flex  
		googletag.defineSlot('/284704979/ambrosiaforheads/AFH_Below_Article_Box_Flex', [300, 250], 'div-gpt-ad-1540251912042-2'+type).defineSizeMapping(mapping[2]).addService(googletag.pubads()).setCollapseEmptyDiv(true);
		
		if (window.width > 767) {
			// AFH Below Article Leaderboard
			googletag.defineSlot('/284704979/ambrosiaforheads/AFH_Below_Article_Leaderboard', [728, 90], 'div-gpt-ad-1540251912042-3'+type).defineSizeMapping(mapping[3]).addService(googletag.pubads()).setCollapseEmptyDiv(true);
		}	
				
		googletag.pubads().setTargeting('AFH_Tags', '2019,9th wonder,Add-2,Ari Lennox,Bandana,bas,Beat Butcha,Benny,Benny the Butcher,Best Hip-Hop Albums,best of,big k.r.i.t.,big krit,black soprano family,BMG,boogie,Boot Camp Clik,bsf,cocoa brovas,Cozz,Daringer,dj premier,Doctor Dot,Dreamville,duck down,EARTHGANG,eminem,Empire,eve,Everything\'s For Sale,Felt,freddie gibbs,Freddie Gibbs &amp; Madlib,gang starr,General Steele,Griselda,guru,Interscope,j. cole,J.I.D.,Jamla,JID,Jim Crow the Musical,Johnny Venus,K.R.I.T. IZ Here,Keep Cool,KRIT IZ HERE,little brother,living legends,Lootpack,madlib,May The Lord Watch,Mello Music Group,Mirrorland,Multi Alumni,murs,Murs &amp; 9th Wonder,omen,One Of The Best Yet,pete rock,phonte,rapper big pooh,rapsody,RCA,Retropolitan,Revenge of the Dreamers,Revenge of the Dreamers III,Revenge Of The Dreamers Part III,Shady,skyzoo,Skyzoo &amp; pete Rock,smif n wessun,Spillage Village,steele,Tek,The All,The Iliad Is Dead and The Odyssey Is Over,the lost boy,The Plugs I Met,the soul council,WWCD,YBN Cordae,Yesterday\'s New Quintet,');
		googletag.pubads().setTargeting('AFH_ID', '97382'); 
		googletag.pubads().setTargeting('AFH_Zone', 'article');
	
				
	googletag.defineSlot('/284704979/ambrosiaforheads/afh_1x1', [1, 1], 'div-gpt-ad-1540251912042-5').addService(googletag.pubads());
	
    googletag.pubads().enableSingleRequest();
    
    /* SORTABLE*/
    deployads.push(function () { 
	    deployads.gpt.enableServices(); 
	});
 
});
</script>	
	<link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css" />
	<script type="text/plain" data-cookieconsent="preferences" src="//script.crazyegg.com/pages/scripts/0073/0201.js" async="async"></script>
    
    <style>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</style>    
    <script type="text/plain" data-cookieconsent="necessary">
    window.single = true;    </script>
    
    <style type='text/css'>Default CSS Comment</style>
<!-- All in One SEO Pack 2.4.5.1 by Michael Torbert of Semper Fi Web Design[861,943] -->
<meta name="description"  content="Ambrosia For Heads&#039; Top 15 Hip-Hop Albums Of 2019 List" />

<meta name="keywords"  content="add-2,jim crow the musical,benny the butcher,benny,the plugs i met,black soprano family,bsf,griselda,gang starr,one of the best yet,dreamville,j. cole,revenge of the dreamers,revenge of the dreamers iii,revenge of the dreamers part iii,earthgang,mirrorland,johnny venus,doctor dot,spillage village,j.i.d.,bas,jid,cozz,ari lennox,omen,interscope,boogie,everything\'s for sale,shady,eminem,big krit,big k.r.i.t.,big k.r.i.t,krit iz here,k.r.i.t. iz here,multi alumni,bmg,freddie gibbs,madlib,freddie gibbs &amp; madlib,bandana,keep cool,rca,lootpack,yesterday\'s new quintet,wwcd,daringer,beat butcha,smif-n-wessun,tek,general steele,steele,the all,boot camp clik,cocoa brovas,duck down,murs,9th wonder,jamla,the soul council,little brother,living legends,felt,murs &amp; 9th wonder,the iliad is dead and the odyssey is over,empire,guru,dj premier,phonte,rapper big pooh,may the lord watch,rapsody,eve,ybn cordae,the lost boy,skyzoo,pete rock,skyzoo &amp; pete rock,mello music group,retropolitan,2019,best of,best hip-hop albums,,freddie gibbs &amp; madlib,murs &amp; 9th wonder,skyzoo &amp; pete rock,smif n wessun" />

<link rel="canonical" href="https://ambrosiaforheads.com/2019/12/best-hiphop-albums-2019/" />
<!-- /all in one seo pack -->
<link rel="dns-prefetch" href="//connect.facebook.net" />
<link rel='dns-prefetch' href='//connect.facebook.net' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/ambrosiaforheads.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.13"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='dilemmacss-css'  href='https://ambrosiaforheads.com/wp-content/plugins/Dilemma/css/dilemma.css?ver=4.9.13' type='text/css' media='all' />
<link rel='stylesheet' id='srp-layout-stylesheet-css'  href='https://ambrosiaforheads.com/wp-content/plugins/special-recent-posts/css/layout.css?ver=4.9.13' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://ambrosiaforheads.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_frontend-css'  href='https://ambrosiaforheads.com/wp-content/plugins/photo-gallery/css/bwg_frontend.css?ver=1.3.69' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_font-awesome-css'  href='https://ambrosiaforheads.com/wp-content/plugins/photo-gallery/css/font-awesome/font-awesome.css?ver=4.6.3' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_mCustomScrollbar-css'  href='https://ambrosiaforheads.com/wp-content/plugins/photo-gallery/css/jquery.mCustomScrollbar.css?ver=1.3.69' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_sumoselect-css'  href='https://ambrosiaforheads.com/wp-content/plugins/photo-gallery/css/sumoselect.css?ver=3.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='mc-brackets-plugin-styles-css'  href='https://ambrosiaforheads.com/wp-content/plugins/mc-brackets/public/assets/css/mc-brackets/jquery-ui-1.10.4.custom.min.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='afh-google-fonts-css'  href='//fonts.googleapis.com/css?family=Roboto%3A400%2C100%2C100italic%2C300%2C300italic%2C400italic%2C500%2C500italic%2C700%2C700italic%2C900%2C900italic%7CRoboto+Condensed%3A300italic%2C400italic%2C700italic%2C400%2C300%2C700%7CRoboto+Slab%3A400%2C100%2C300%2C700%7COpen+Sans%3A300italic%2C400italic%2C600italic%2C700italic%2C800italic%2C400%2C600%2C700%2C300%2C800&#038;ver=4.9.13' type='text/css' media='all' />
<link rel='stylesheet' id='afh-bootstrap-css'  href='https://ambrosiaforheads.com/wp-content/themes/ambrosiaforheads_v2/stylesheets/bootstrap.min.css?ver=4.9.13' type='text/css' media='all' />
<link rel='stylesheet' id='afh-style-css'  href='https://ambrosiaforheads.com/wp-content/themes/ambrosiaforheads_v2/stylesheets/screen.css?ver=4.6.6' type='text/css' media='all' />
<script type='text/javascript' src='https://ambrosiaforheads.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://ambrosiaforheads.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var dilemma_vars = {"ajaxurl":"https:\/\/ambrosiaforheads.com\/wp-admin\/admin-ajax.php","str_voted_leftview":" disagrees","str_voted_rightview":" agrees"};
/* ]]> */
</script>
<script type='text/javascript' src='https://ambrosiaforheads.com/wp-content/plugins/Dilemma/js/dilemma.js?ver=4.9.13'></script>
<script type='text/javascript' src='https://ambrosiaforheads.com/wp-content/plugins/photo-gallery/js/bwg_frontend.js?ver=1.3.69'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var bwg_objectsL10n = {"bwg_select_tag":"Select Tag","bwg_search":"Search"};
/* ]]> */
</script>
<script type='text/javascript' src='https://ambrosiaforheads.com/wp-content/plugins/photo-gallery/js/jquery.sumoselect.min.js?ver=3.0.2'></script>
<script type='text/javascript' src='https://ambrosiaforheads.com/wp-content/plugins/photo-gallery/js/jquery.mobile.js?ver=1.3.69'></script>
<script type='text/javascript' src='https://ambrosiaforheads.com/wp-content/plugins/photo-gallery/js/jquery.mCustomScrollbar.concat.min.js?ver=1.3.69'></script>
<script type='text/javascript' src='https://ambrosiaforheads.com/wp-content/plugins/photo-gallery/js/jquery.fullscreen-0.4.1.js?ver=0.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var bwg_objectL10n = {"bwg_field_required":"field is required.","bwg_mail_validation":"This is not a valid email address.","bwg_search_result":"There are no images matching your search."};
/* ]]> */
</script>
<script type='text/javascript' src='https://ambrosiaforheads.com/wp-content/plugins/photo-gallery/js/bwg_gallery_box.js?ver=1.3.69'></script>
<script type='text/javascript' src='https://ambrosiaforheads.com/wp-content/plugins/mc-brackets/public/assets/js/jquery-ui-1.10.4.custom.min.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://ambrosiaforheads.com/wp-content/plugins/mc-brackets/public/assets/js/public.js?ver=1.0.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sranalytics = {"version":"0.1.4","pid":"515dec564240cfb7af000011","iframe":"0","title":"Ambrosia For Heads\u2019 Top 15 Hip-Hop Albums Of 2019 List","url":"https:\/\/ambrosiaforheads.com\/2019\/12\/best-hiphop-albums-2019\/","date":"2019-12-18 16:04:23","channels":["best-albums-of-2019"],"tags":["2019","9th wonder","Add-2","Ari Lennox","Bandana","bas","Beat Butcha","Benny","Benny the Butcher","Best Hip-Hop Albums","best of","big k.r.i.t.","big krit","black soprano family","BMG","boogie","Boot Camp Clik","bsf","cocoa brovas","Cozz","Daringer","dj premier","Doctor Dot","Dreamville","duck down","EARTHGANG","eminem","Empire","eve","Everything\\'s For Sale","Felt","freddie gibbs","Freddie Gibbs &amp; Madlib","gang starr","General Steele","Griselda","guru","Interscope","j. cole","J.I.D.","Jamla","JID","Jim Crow the Musical","Johnny Venus","K.R.I.T. IZ Here","Keep Cool","KRIT IZ HERE","little brother","living legends","Lootpack","madlib","May The Lord Watch","Mello Music Group","Mirrorland","Multi Alumni","murs","Murs &amp; 9th Wonder","omen","One Of The Best Yet","pete rock","phonte","rapper big pooh","rapsody","RCA","Retropolitan","Revenge of the Dreamers","Revenge of the Dreamers III","Revenge Of The Dreamers Part III","Shady","skyzoo","Skyzoo &amp; pete Rock","smif n wessun","Spillage Village","steele","Tek","The All","The Iliad Is Dead and The Odyssey Is Over","the lost boy","The Plugs I Met","the soul council","WWCD","YBN Cordae","Yesterday\\'s New Quintet"],"authors":["Ambrosia For Heads"]};
/* ]]> */
</script>
<script type='text/javascript' src='https://ambrosiaforheads.com/wp-content/plugins/sranalytics_wordpress-0.1.5/javascripts/sranalytics.js?ver=4.9.13'></script>
<link rel='https://api.w.org/' href='https://ambrosiaforheads.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://ambrosiaforheads.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://ambrosiaforheads.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='A New Mos Def &#038; Al Green Mashup Brings Much Love &#038; Happiness (Audio)' href='https://ambrosiaforheads.com/2019/12/a-new-mos-def-al-green-mashup-brings-much-love-happiness-audio/' />
<link rel='next' title='Tekashi 6ix9ine Is Expected To Be Released From Prison In 2020' href='https://ambrosiaforheads.com/2019/12/tekashi-6ix9ine-sentence-release/' />
<link rel='shortlink' href='https://ambrosiaforheads.com/?p=97382' />
<link rel="alternate" type="application/json+oembed" href="https://ambrosiaforheads.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fambrosiaforheads.com%2F2019%2F12%2Fbest-hiphop-albums-2019%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://ambrosiaforheads.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fambrosiaforheads.com%2F2019%2F12%2Fbest-hiphop-albums-2019%2F&#038;format=xml" />
<script async>(function(s,u,m,o,j,v){j=u.createElement(m);v=u.getElementsByTagName(m)[0];j.async=1;j.src=o;j.dataset.sumoSiteId='f9085244102f989ef6d91933bfe9e3da9fe87b1fa4482df43d57f7ea24d4888d';j.dataset.sumoPlatform='wordpress';v.parentNode.insertBefore(j,v)})(window,document,'script','//load.sumo.com/');</script><script type="text/javascript">window.wp_data = {"ajax_url":"https:\/\/ambrosiaforheads.com\/wp-admin\/admin-ajax.php","post":{"title":"Ambrosia For Heads\u2019 Top 15 Hip-Hop Albums Of 2019 List","date":null}};</script><meta property="og:site_name" content="Ambrosia For Heads" />
<meta property="og:type" content="article" />
<meta property="og:locale" content="en_US" />
<meta property="fb:app_id" content="149229425165568" />
<meta property="og:url" content="https://ambrosiaforheads.com/2019/12/best-hiphop-albums-2019/" />
<meta property="og:title" content="Ambrosia For Heads’ Top 15 Hip-Hop Albums Of 2019 List" />
<meta property="og:description" content="It is that season when “best of” lists abound and, in a year that featured some remarkable music from artists across the landscape, 2019 kept Hip-Hop fans on the edge&hellip;" />
<meta property="og:image" content="https://ambrosiaforheads.com/wp-content/uploads/2019/12/2019-best-albums-afh.png" />
<meta property="og:image:width" content="730" />
<meta property="og:image:height" content="411" />
<meta property="article:published_time" content="2019-12-18T16:04:23+00:00" />
<meta property="article:modified_time" content="2019-12-18T22:03:12+00:00" />
<meta property="article:author" content="https://ambrosiaforheads.com/author/ambrosia-for-heads/" />
<meta property="article:section" content="Best Albums Of 2019" />
<meta property="article:tag" content="2019" />
<meta property="article:tag" content="9th wonder" />
<meta property="article:tag" content="Add-2" />
<meta property="article:tag" content="Ari Lennox" />
<meta property="article:tag" content="Bandana" />
<meta property="article:tag" content="bas" />
<meta property="article:tag" content="Beat Butcha" />
<meta property="article:tag" content="Benny" />
<meta property="article:tag" content="Benny the Butcher" />
<meta property="article:tag" content="Best Hip-Hop Albums" />
<meta property="article:tag" content="best of" />
<meta property="article:tag" content="big k.r.i.t." />
<meta property="article:tag" content="big krit" />
<meta property="article:tag" content="black soprano family" />
<meta property="article:tag" content="BMG" />
<meta property="article:tag" content="boogie" />
<meta property="article:tag" content="Boot Camp Clik" />
<meta property="article:tag" content="bsf" />
<meta property="article:tag" content="cocoa brovas" />
<meta property="article:tag" content="Cozz" />
<meta property="article:tag" content="Daringer" />
<meta property="article:tag" content="dj premier" />
<meta property="article:tag" content="Doctor Dot" />
<meta property="article:tag" content="Dreamville" />
<meta property="article:tag" content="duck down" />
<meta property="article:tag" content="EARTHGANG" />
<meta property="article:tag" content="eminem" />
<meta property="article:tag" content="Empire" />
<meta property="article:tag" content="eve" />
<meta property="article:tag" content="Everything&#039;s For Sale" />
<meta property="article:tag" content="Felt" />
<meta property="article:tag" content="freddie gibbs" />
<meta property="article:tag" content="Freddie Gibbs &amp; Madlib" />
<meta property="article:tag" content="gang starr" />
<meta property="article:tag" content="General Steele" />
<meta property="article:tag" content="Griselda" />
<meta property="article:tag" content="guru" />
<meta property="article:tag" content="Interscope" />
<meta property="article:tag" content="j. cole" />
<meta property="article:tag" content="J.I.D." />
<meta property="article:tag" content="Jamla" />
<meta property="article:tag" content="JID" />
<meta property="article:tag" content="Jim Crow the Musical" />
<meta property="article:tag" content="Johnny Venus" />
<meta property="article:tag" content="K.R.I.T. IZ Here" />
<meta property="article:tag" content="Keep Cool" />
<meta property="article:tag" content="KRIT IZ HERE" />
<meta property="article:tag" content="little brother" />
<meta property="article:tag" content="living legends" />
<meta property="article:tag" content="Lootpack" />
<meta property="article:tag" content="madlib" />
<meta property="article:tag" content="May The Lord Watch" />
<meta property="article:tag" content="Mello Music Group" />
<meta property="article:tag" content="Mirrorland" />
<meta property="article:tag" content="Multi Alumni" />
<meta property="article:tag" content="murs" />
<meta property="article:tag" content="Murs &amp; 9th Wonder" />
<meta property="article:tag" content="omen" />
<meta property="article:tag" content="One Of The Best Yet" />
<meta property="article:tag" content="pete rock" />
<meta property="article:tag" content="phonte" />
<meta property="article:tag" content="rapper big pooh" />
<meta property="article:tag" content="rapsody" />
<meta property="article:tag" content="RCA" />
<meta property="article:tag" content="Retropolitan" />
<meta property="article:tag" content="Revenge of the Dreamers" />
<meta property="article:tag" content="Revenge of the Dreamers III" />
<meta property="article:tag" content="Revenge Of The Dreamers Part III" />
<meta property="article:tag" content="Shady" />
<meta property="article:tag" content="skyzoo" />
<meta property="article:tag" content="Skyzoo &amp; pete Rock" />
<meta property="article:tag" content="smif n wessun" />
<meta property="article:tag" content="Spillage Village" />
<meta property="article:tag" content="steele" />
<meta property="article:tag" content="Tek" />
<meta property="article:tag" content="The All" />
<meta property="article:tag" content="The Iliad Is Dead and The Odyssey Is Over" />
<meta property="article:tag" content="the lost boy" />
<meta property="article:tag" content="The Plugs I Met" />
<meta property="article:tag" content="the soul council" />
<meta property="article:tag" content="WWCD" />
<meta property="article:tag" content="YBN Cordae" />
<meta property="article:tag" content="Yesterday&#039;s New Quintet" />
	
	<script type="text/plain" data-cookieconsent="marketing">
function sendGAEvent(category, action, label) {
	if (category !== undefined && action != undefined && label != undefined) {
		
		gtag('event', action, {
		  'event_category': category,
		  'event_label': label
		});
		
	}	
}
function openInNewTab(href, newTab) {
	if (newTab == '_blank') {
		var win = window.open(href, '_blank');
		win.focus();
	}
	else {
		window.location=href;
	}	
}
	
jQuery(document).ready(function($){
    
    window.width = window.innerWidth || document.documentElement.clientWidth || document.body.clientWidth;
         
    if (window.width > 767) {
    	
    	/*
	    setTimeout(function(){   
			$('body.single, body.home').removeClass('header-fixed'); 	
	    }, 4000);
	    */
	    
	    if (window.single) {
		    

		    $('.entry-content-wrapper .entry > p').each(function(){
			   if ($(this).html().trim() == '') {
				   $(this).remove();
			   } 
		    });
		    
		    var count = 0;
		    
		    $('.entry-content-wrapper .entry > p').each(function(i){
			    var html = $(this).html().trim().substring(0, 2);
			    if (html == '<a' || html == '<i') {
				    count--;
			    }
			    if (count == 2) {
				    $(this).after('<div class="in-content-ad" style="text-align: center;margin: 1em 0;"><div id=\'div-gpt-ad-1540251912042-2-desktop\' style=\'margin:1em auto;text-align:center;clear: both;padding: 1em 0;\'></div></div>')
					googletag.cmd.push(function() { 
						
						/* SORTABLE */
						deployads.push(function() { 
							deployads.gpt.display("div-gpt-ad-1540251912042-2-desktop");
						}); 
						
						/* googletag.display('div-gpt-ad-1540251912042-2-desktop'); */
						
					});
					return false;
			    }
			    count++;
		    });
		    				    
	    }
	    
	    	    
	    	
	    	/* AFH TV Promotion */
		    var afhtv_enabled_desktop = '';
		    if (afhtv_enabled_desktop == '1') {
			    //if (document.URL.indexOf('afhtv')>-1) {
				    $('.afhtv-promo-desktop').addClass('visible');
				    var text = $('.afhtv-text').html();
			    	text = text.replace(/AFH TV/g, '<a href="//www.afhtv.com/" target="_blank" data-type="AFH TV Link" data-format="desktop">AFH TV</a>');
			    	$('.afhtv-text').html(text);
			    //}
		    }
	    	
	    
	    	    			    
    }
    else {
	    
	    if (window.home) {
		    
		    $('.top-home-posts .col-md-4').each(function(i){
			    
			    if (i == 1) {
				    
				    $(this).append('<div class="mobile-ad-home"></div>');
				    
			    }
			    
		    });
		    
		    $('.middle-home-posts .top-social-ad-block-mobile').detach().appendTo('.mobile-ad-home');
		    
	    }
	    
	    if (window.single) {
		    
		    $('.entry > p').each(function(){
			   if ($(this).html().trim() == '') {
				   $(this).remove();
			   } 
		    });
		    
		    var count = 0;
		    
		    $('.entry > p').each(function(i){
			    var html = $(this).html().trim().substring(0, 2);
			    if (html == '<a') {
				    count--;
			    }
			    if (count == 2) {
				    $(this).after('<div class="in-content-ad" style="text-align: center;margin: 2em 0;"><div id="div-gpt-ad-1540251912042-2-mobile"></div></div>')
				    
					googletag.cmd.push(function() { 
						
						/* SORTABLE */
						deployads.push(function() { deployads.gpt.display("div-gpt-ad-1540251912042-2-mobile"); });
						
						/* googletag.display('div-gpt-ad-1540251912042-2-mobile'); */
						
					});
					
					return false;
			    }
			    count++;
		    });
		    
		    $('.single-mobile-ad').remove();
		    
	    }
	    
	    	    
	     	/* AFH TV Promotion */
		    var afhtv_enabled_mobile = '1';
		    if (afhtv_enabled_mobile == '1') {
			    //if (document.URL.indexOf('afhtv')>-1) {
			    	$('.afhtv-promo-mobile').addClass('visible');
			    	var text = $('.afhtv-text').html();
			    	text = text.replace(/AFH TV/g, '<a href="//www.afhtv.com/" target="_blank" data-type="AFH TV Link" data-format="mobile">AFH TV</a>');
			    	$('.afhtv-text').html(text);
			    //}
			    
		    }
	    
	    	    
    }
    
    $('.entry').on('click', '.afhtv-promo a', function(e){
		e.preventDefault();
		var href = $(this).attr('href'),
			newTab = $(this).attr('target'),
			type = $(this).data('type'),
			format = $(this).data('format');
		sendGAEvent('AFH TV','Promo - '+type+' - '+format,href);
		setTimeout(function(){
			openInNewTab(href, newTab);
		}, 250);
	});
	    		   
});
</script>	
</head>
<body class="post-template-default single single-post postid-97382 single-format-standard">
	
    <div id="fb-root"></div>
   
    <noscript><img height="1" width="1" alt="" style="display:none" src="https://www.facebook.com/tr?id=1524742197780495&amp;ev=PixelInitialized" /></noscript>
    
    <!-- Google Tag Manager (noscript) -->
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KZV522D"
	height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
	<!-- End Google Tag Manager (noscript) -->
    
    <header class="header">
        
        <div class="container">
	        
            <div class="row">
	            
                <div class="logo-and-nav col-md-6 col-sm-12">

                    <h1 class="site-title">
                        <a href="https://ambrosiaforheads.com">
                            AFH
                        </a>
                        <span>Ambrosia for Heads</span>
                    </h1>

                    <!-- Main navigation -->
                    <nav class="main-header-navigation navigation collapse navbar-collapse" id="main-header-navigation">
                        <ul id="menu-main" class="menu"><li id="menu-item-14576" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14576"><a title="Fresh" href="https://ambrosiaforheads.com/category/fresh/">Fresh</a></li>
<li id="menu-item-14570" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14570"><a title="Old School" href="https://ambrosiaforheads.com/category/fresh/old-school-8/">Throwback</a></li>
<li id="menu-item-14571" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14571"><a title="Audio" href="https://ambrosiaforheads.com/category/fresh/audio/">Audio</a></li>
<li id="menu-item-14572" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14572"><a title="Video" href="https://ambrosiaforheads.com/category/fresh/video/">Video</a></li>
<li id="menu-item-92718" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-92718"><a href="http://afhtv.com">AFH TV</a></li>
</ul>                        <div class="mobile-search-form visible-sm visible-xs">
                            <form method="get" action="https://ambrosiaforheads.com" name="searchform">
	<input type="text" class="input-text"  placeholder="Search Here" name="s" id="s" value="" />
	<input type="submit" class="input-submit" value="Search" />
</form>
                        </div>
                    </nav>

                    <button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#main-header-navigation">
                        <span class="sr-only">Toggle navigation</span>
                        <span class="icon-bar"></span>
                        <span class="icon-bar"></span>
                        <span class="icon-bar"></span>
                    </button>
                    
                </div>
                <div class="search-and-social col-md-6 col-sm-12 visible-lg visible-md">
                    <div class="inner align-right">
                        <div class="search">
                            <form method="get" action="https://ambrosiaforheads.com" name="searchform">
	<input type="text" class="input-text"  placeholder="Search Here" name="s" id="s" value="" />
	<input type="submit" class="input-submit" value="Search" />
</form>
                        </div>
                        <ul class="sm-links inline-block no-margin">
                            <li><a href="https://www.facebook.com/ambrosiaforheads" target="_blank" class="fragments-sm-icon-header-facebook-new">Facebook</a></li>
                            <li><a href="https://www.youtube.com/aforhtv" target="_blank" class="fragments-sm-icon-header-youtube-new">YouTube</a></li>
                            <li><a href="https://twitter.com/ambrosia4heads" target="_blank" class="fragments-sm-icon-header-twitter-new">Twitter</a></li>
                            <li><a href="https://soundcloud.com/ambrosia-for-heads" target="_blank" class="fragments-sm-icon-header-soundcloud">SoundCloud</a></li>
                            <li><a href="https://instagram.com/ambrosia4heads/" target="_blank" class="fragments-sm-icon-header-instagram">Instagram</a></li>
                        </ul>
                    </div>
                </div>
            </div>
            
        </div>
        
        <div class="header-ad text-center article-ad-block visible-md visible-lg">
            <!-- /33196227/AFH_Article_Leaderboard
<div id='div-gpt-ad-1477791514607-0' style='min-height:90px; display: inline-block; margin: 0 auto;'>
<script>
window.width = window.innerWidth || document.documentElement.clientWidth || document.body.clientWidth;

if (window.width > 767) { 
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1477791514607-0'); });
}
</script>
</div>
-->

<!-- /284704979/ambrosiaforheads/AFH_Above_Article_Leaderboard_Flex DESKTOP -->
<div id='div-gpt-ad-1540251912042-0-desktop'>
<script>
window.width = window.innerWidth || document.documentElement.clientWidth || document.body.clientWidth;
if (window.width > 767) {

/* SORTABLE */					deployads.push(function() { deployads.gpt.display("div-gpt-ad-1540251912042-0-desktop"); });

/* googletag.display('div-gpt-ad-1540251912042-0-desktop'); }); */

}
</script>
</div>        </div>
      
        <!--[if lt IE 9]>
        <div class="row">
            <div class="col-md-12 upgradenotice">
                You are using an outdated version of Internet Explorer. To best experience this site, please go to Windows Updates and install the latest version.
            </div>
        </div>
        <![endif]-->
    </header>
    <div id="content-height-spacer" class="hidden-xs visible-sm visible-lg visible-md"></div>
    
    	
	<!-- /284704979/ambrosiaforheads/afh_1x1 -->
	<div id='div-gpt-ad-1540251912042-5' style='height:1px; width:1px;'>
		<script type="text/plain" data-cookieconsent="marketing">
		deployads.push(function() { deployads.gpt.display("div-gpt-ad-1540251912042-5"); });
		</script>
	</div>
<div class="container main">

	<div class="row top-row">
		
				
			<!-- /284704979/ambrosiaforheads/AFH_Above_Box MOBILE
			<div id='div-gpt-ad-1540251912042-1-mobile' style='height:250px; width:300px;margin:0 auto 2em;display:block'>
			<script type="text/javascript" data-cookieconsent="marketing">
			window.width = window.innerWidth || document.documentElement.clientWidth || document.body.clientWidth;
			if (window.width < 768) {
			
				googletag.cmd.push(function() { googletag.display('div-gpt-ad-1540251912042-1-mobile'); });
			
			}
			</script>
			</div>
			-->
		
				
		<div id="post-content-wrapper" class="col-md-8 post-content pull-right">

			
				<div class="entry-content-wrapper" id="post-97382" data-post-permalink="/2019/12/best-hiphop-albums-2019/">
	<div class="byline">
		<span class="date">December 18, 2019</span>
		<span class="divider">|</span>
		<span class="author">Published By <a href="https://ambrosiaforheads.com/author/ambrosia-for-heads/" title="Posts by Ambrosia For Heads" rel="author">Ambrosia For Heads</a></span>
	</div>

			
		<h1 class="entry-title">Ambrosia For Heads’ Top 15 Hip-Hop Albums Of 2019 List</h1>

	
	
<style>
ul.share-buttons{
  list-style: none;
  padding: 0;
}

ul.share-buttons li{
  display: inline;
}

ul.share-buttons .sr-only{
  position: absolute;
  clip: rect(1px 1px 1px 1px);
  clip: rect(1px, 1px, 1px, 1px);
  padding: 0;
  border: 0;
  height: 1px;
  width: 1px;
  overflow: hidden;
}

ul.share-buttons img{
  width: 32px;
}
</style>

<div class="social-media-buttons" style="padding: 10px 0 0px;">
	
	<!--
	<div class="sm-btn-wrapper btn-facebook">
		<div class="fb-share-button" data-type="box_count" data-href="https://ambrosiaforheads.com/2019/12/best-hiphop-albums-2019/"></div>
	</div>
	<div class="sm-btn-wrapper btn-twitter">
		<a href="https://twitter.com/share" class="twitter-share-button" data-text="Ambrosia For Heads’ Top 15 Hip-Hop Albums Of 2019 List" data-url="https://ambrosiaforheads.com/2019/12/best-hiphop-albums-2019/" data-via="ambrosia4heads" data-lang="en" data-count="vertical">Tweet</a>
		<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
	</div>
	<div class="sm-btn-wrapper btn-google-plus">
		<div class="g-plusone" data-size="tall" data-href="https://ambrosiaforheads.com/2019/12/best-hiphop-albums-2019/"></div>
		<script type="text/javascript">
		  (function() {
		    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
		    po.src = 'https://apis.google.com/js/plusone.js';
		    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
		  })();
		</script>
	</div>
	<div class="sm-btn-wrapper btn-pinterest">
		<a href="https://www.pinterest.com/pin/create/button/?url=https://ambrosiaforheads.com/2019/12/best-hiphop-albums-2019/&media=https://ambrosiaforheads.com/wp-content/uploads/2019/12/2019-best-albums-afh.png&description=Next%20stop%3A%20Pinterest" data-pin-do="buttonPin" data-pin-config="above">
	        <img src="//assets.pinterest.com/images/pidgets/pin_it_button.png" />
	    </a>
	    <script type="text/javascript">
		(function(d){
		    var f = d.getElementsByTagName('SCRIPT')[0], p = d.createElement('SCRIPT');
		    p.type = 'text/javascript';
		    p.async = true;
		    p.src = '//assets.pinterest.com/js/pinit.js';
		    f.parentNode.insertBefore(p, f);
		}(document));
		</script>
	</div>
	<div class="sm-btn-wrapper btn-email">
		<a href="http://eepurl.com/sOLZf" target="_blank">
			<i class="fragments-sm-email-article"></i>
			<span>Email</span>
		</a>
	</div>
	-->
	
	<ul class="share-buttons">
	  
	  <li><a href="#" title="Share on Facebook" target="_blank" onclick="window.open('https://www.facebook.com/sharer/sharer.php?u=' + encodeURIComponent(document.URL) + '&quote=' + encodeURIComponent(document.URL)); return false;"><img alt="Share on Facebook" src="https://ambrosiaforheads.com/wp-content/themes/ambrosiaforheads_v2/images/social_flat_rounded_rects_svg/Facebook.svg" /></a></li>
	  <li><a href="#" target="_blank" title="Tweet" onclick="window.open('https://twitter.com/intent/tweet?text=' + encodeURIComponent(document.title) + ':%20'  + encodeURIComponent(document.URL)); return false;"><img alt="Tweet" src="https://ambrosiaforheads.com/wp-content/themes/ambrosiaforheads_v2/images/social_flat_rounded_rects_svg/Twitter.svg" /></a></li>
	  <li><a href="#" target="_blank" title="Share on Google+" onclick="window.open('https://plus.google.com/share?url=' + encodeURIComponent(document.URL)); return false;"><img alt="Share on Google+" src="https://ambrosiaforheads.com/wp-content/themes/ambrosiaforheads_v2/images/social_flat_rounded_rects_svg/Google+.svg" /></a></li>
	  <li><a href="#" target="_blank" title="Pin it" onclick="window.open('http://pinterest.com/pin/create/button/?url=' + encodeURIComponent(document.URL) + '&description=' +  encodeURIComponent(document.title)); return false;"><img alt="Pin it" src="https://ambrosiaforheads.com/wp-content/themes/ambrosiaforheads_v2/images/social_flat_rounded_rects_svg/Pinterest.svg" /></a></li>
	  <li><a href="#" target="_blank" title="Share on LinkedIn" onclick="window.open('http://www.linkedin.com/shareArticle?mini=true&url=' + encodeURIComponent(document.URL) + '&title=' +  encodeURIComponent(document.title)); return false;"><img alt="Share on LinkedIn" src="https://ambrosiaforheads.com/wp-content/themes/ambrosiaforheads_v2/images/social_flat_rounded_rects_svg/LinkedIn.svg" /></a></li>
	  <li><a href="#" target="_blank" title="Send email" onclick="window.open('mailto:?subject=' + encodeURIComponent(document.title) + '&body=' +  encodeURIComponent(document.URL)); return false;"><img alt="Send email" src="https://ambrosiaforheads.com/wp-content/themes/ambrosiaforheads_v2/images/social_flat_rounded_rects_svg/Email.svg" /></a></li>
	
	</ul>

</div>

	
	<div class="article-facebook-like-box">
		<div class="fb-page" data-href="https://www.facebook.com/ambrosiaforheads/" data-small-header="true" data-adapt-container-width="true" data-hide-cover="true" data-show-facepile="false"><blockquote cite="https://www.facebook.com/ambrosiaforheads/" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/ambrosiaforheads/">Ambrosia For Heads</a></blockquote></div>
	</div>

	<div class="entry">

				
	<div class="afhtv-promo afhtv-promo-mobile">
				
		<div class="afhtv-text">
			Hip-Hop Fans, please subscribe to AFH TV, a streaming video service focused on real Hip-Hop culture. We already have exclusive interviews, documentaries, and rare freestyles featuring some of Rap’s most iconic artists and personalities, and much more is coming--movies, TV series, talk shows. We need your support. It is only $1.99/month or $12/year, and is available on iOS, Android, Roku, Apple TV, Amazon Fire and Google TV, for all subscribers. Start your 7-day free trial now. Thank you.		</div>
		
		<div class="afhtv-images">
			<div class="app-stores">
				<a href="https://itunes.apple.com/us/app/afh-tv/id1417312741?ls=1&mt=8" target="_blank" data-type="App Store" data-format="mobile">
					<img class="app-store" src="https://ambrosiaforheads.com/wp-content/themes/ambrosiaforheads_v2/images/app-store-1.png" alt="App Store" />
				</a>
				<a href="https://play.google.com/store/apps/details?id=com.afhtv" target="_blank" data-type="Google Play" data-format="mobile">
					<img class="google-play" src="https://ambrosiaforheads.com/wp-content/themes/ambrosiaforheads_v2/images/google-play-1.png" alt="App Store" />
				</a>
			</div>
			<a href="//www.afhtv.com/" target="_blank" data-type="Credit Cards" data-format="mobile">
				<img class="payment-cards" src="https://ambrosiaforheads.com/wp-content/themes/ambrosiaforheads_v2/images/payment-cards.png" alt="Payment methods" />
			</a>
		</div>

	</div>

		
		<p>
<div class="fb-social-plugin fb-like" data-font="lucida grande" data-ref="above-post" data-href="https://ambrosiaforheads.com/2019/12/best-hiphop-albums-2019/" data-layout="button_count" data-share="true" data-width="450"></div>
</p><p><div class="mobile-ad visible-xs"><!-- Mobile one --><script src="//ib.3lift.com/ttj?inv_code=ambrosiaforheads_article_infeed_mobile"></script></div></p><p>It is that season when “best of” lists abound and, in a year that featured some remarkable music from artists across the landscape, 2019 kept Hip-Hop fans on the edge of our seats. There were reunions, surprise collaborations, and show-stopping debut albums. The year also featured innovative label compilations, unexpected additions to highly-respected discographies, and impressive comebacks. Now is an excellent time to reflect on the best ones, as decided by the team at <em>Ambrosia For Heads</em>.
</p><p>Stay tuned for the annual bracket-style tournament to decide 2019&#8217;s top LP next month. However, in the meantime, celebrate one incredible year for Hip-Hop with <em>Ambrosia For Heads</em>‘ Best Albums Of 2019 (listed alphabetically by artist):
<p style="text-align: left;"><strong>Add-2 &#8211; <em>Jim Crow The Musical</em></strong>
</p><p><img class="size-full wp-image-98116 aligncenter" src="https://ambrosiaforheads.com/wp-content/uploads/2019/12/add2-jim_crow-the_musical.jpg" alt="" width="500" height="500" srcset="https://ambrosiaforheads.com/wp-content/uploads/2019/12/add2-jim_crow-the_musical.jpg 500w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/add2-jim_crow-the_musical-150x150.jpg 150w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/add2-jim_crow-the_musical-300x300.jpg 300w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/add2-jim_crow-the_musical-100x100.jpg 100w" sizes="(max-width: 500px) 100vw, 500px" />
</p><p>Chicago, Illinois’ own Add-2 (also known as Andre Daniels) followed up his acclaimed 2015 Jamla Records release <a href="https://open.spotify.com/album/2Ci8TjbcurSlqmEfXY1Zqs?si=7dqkB5GPSTCeOtDlAcZHlA" target="_blank" rel="noopener"><em>Prey For The Poor</em></a> with a conceptual, timely, and socially-conscious effort, <a href="https://ambrosiaforheads.com/2019/11/add-2-jim-crow-the-musical-album-steam/" target="_blank" rel="noopener"><em>Jim Crow The Musical</em></a>. The 19-track, 57-minute audio adventure (narrated by <em>A Different World </em>actor Kadeem Hardison) takes listeners up-and-down the Mason-Dixon line with songs that touch on subjects relevant to Black folks in America. The veteran lyricist opens in such a theatrical way, not unlike <a href="https://ambrosiaforheads.com/2016/02/kendrick-lamars-to-pimp-a-butterfly-vs-commons-like-water-for-chocolate-which-is-better/" target="_blank" rel="noopener">Kendrick Lamar’s <em>To Pimp a Butterfly</em></a>, where listeners have no choice but to lock yourself in and get ready for the ride. <em>Jim Crow </em>offers life lessons that cover topics such as self-determination (<a href="https://www.youtube.com/watch?v=vmo2tN_HFtI" target="_blank" rel="noopener">“Git Your Hand Out My Pocket”</a>), Black Love (<a href="https://www.youtube.com/watch?v=YDcsSbYh7k4" target="_blank" rel="noopener">“Jump The Broom,”</a>), how to maneuver the streets (<a href="https://www.youtube.com/watch?v=szyaLEH1Llc" target="_blank" rel="noopener">“Young Ni**as”</a>), and staying alive (<a href="https://www.youtube.com/watch?v=iYmiXJPGfpw" target="_blank" rel="noopener">“Hashtag”</a>). These songs are sprinkled with references to Hip-Hop, literature, and modern pop culture. In an age where we’re reading stories — almost in real-time — about people of color being murdered by the police, vilified in the media, and condemned by politicians, Add-2’s contribution serves as a balm on an open wound. &#8211; Kevito Clark
</p><p><span class="s1"><strong>Released:</strong> November 25, 2019<br />
<strong>Label:</strong> Add-2 Productions<br />
<strong>Guests:</strong> Koku Gonza, Accapella, Andy Allo, Brittney Carter, Oliv Blu, Sam Trump, K. Love, Elisa Latrice, YAW, Point Of Realization, Natalie Oliveri, Kadeem Hardison, Phonte, Sy Messi, Emilio Al Sharief, Cam Be, Calvin Carter, Jeff Gibbs, Johndavid Provitt, Arrington Porter, John Renaissance, Kenneth Leftridge, Teo The Artist, DJ Scend, Jon Content, T.L. Williams, Jacob Thomas<br />
<strong>Producers:</strong> Jadah Arrington, Sirplus, IIL Meel, Jeff Miller, Neak, Disrupt, Slot-A, INTL MC, J-Rell</span>
</p><p>&nbsp;
</p><p><strong>Benny The Butcher &#8211; <em>The Plugs I Met</em></strong>
</p><p><img class="size-full wp-image-98118 aligncenter" src="https://ambrosiaforheads.com/wp-content/uploads/2019/12/Benny-The-Butcher-The-Plugs-I-Met-1561127864-640x629.jpg" alt="" width="500" height="500" srcset="https://ambrosiaforheads.com/wp-content/uploads/2019/12/Benny-The-Butcher-The-Plugs-I-Met-1561127864-640x629.jpg 500w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/Benny-The-Butcher-The-Plugs-I-Met-1561127864-640x629-150x150.jpg 150w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/Benny-The-Butcher-The-Plugs-I-Met-1561127864-640x629-300x300.jpg 300w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/Benny-The-Butcher-The-Plugs-I-Met-1561127864-640x629-100x100.jpg 100w" sizes="(max-width: 500px) 100vw, 500px" />
</p><p>Seasoning his craft <a href="https://www.afhtv.com/videos/benny-the-butcher-explains-why-rap-is-a-grown-man-s-game" target="_blank" rel="noopener">for over two decades</a>, <a href="https://open.spotify.com/album/5So31JibrTO74WvuCozsAb?si=jchitFjZRGS5WnFPvx2NoQ" target="_blank" rel="noopener">Benny The Butcher’s <i>The Plugs I Met</i></a> is the grand culmination of a life spent balancing Hip-Hop and hustling. A veteran in both fields, the thirty-something MC from Buffalo, New York <a href="https://ambrosiaforheads.com/2019/06/benny-the-butcher-plugs-i-met-interview-video/">has perfected the art of chronicling street-inspired tales throughout his career</a>. No effort of his more vivid and expertly rendered than <i>The Plugs I Met, </i>the Griselda warhorse (and Black Soprano Family founder) is at his storytelling peak alongside some of Rap’s finest street couriers. Highlighting those choice pairings is the second track, <a href="https://ambrosiaforheads.com/2019/06/benny-butcher-black-thought-song-rap/">&#8220;Crowns For Kings,&#8221;</a> in which Black Thought accompanies Benny over &#8217;70s Memphis Soul. In his first verse of the project, Benny delivers <i>“I’m fresh out of luck, I’m here ‘cause I deserve to be, ni**a / I sat back, a vet, and watched beginners winnin’ my belts / Burned my bridges, came back a good swimmer like Phelps.” </i>That robust self-assurance is a common theme throughout, as B.E.N.N.Y. has grasped his paid dues and demands his seat at the throne. The coveted kingship is aided even more so by enlisting street and Rap royalty in <a href="https://open.spotify.com/track/4qQ99MskaNMqZWvMLkHrZw?si=204blDfNTvu9b6o8cqL8qQ">Jadakiss</a> and <a href="https://ambrosiaforheads.com/2019/06/pusha-t-benny-griselda-18-wheeler-audio/" target="_blank" rel="noopener">Pusha-T</a> for two separate brawny tracks. The LP benefits from a no-nonsense approach, carrying very limited choruses and focusing on tenacious wordplay. While many albums laced with unlawful subject matter can toe the line of hype, there are certainly no fabricated characters within Benny’s memoirs. That contrast of credibility is emphasized on <a href="https://open.spotify.com/track/0YNuDTUKajDpmNWjunPhdi?si=7_iLaXqvRWCS-c5b-gofLA">&#8220;Took The Money To The Plug’s House,&#8221;</a> where Benny states <i>“I damn near don’t pray no more / Only to an eighth of raw / A fork and the mayo jar / Numbers, you inflated yours, you got a created buzz / My flow got the fans rethinking who the greatest was.” </i><span class="s1">True to Benny and the album’s theme of keeping all operations tight and fruitful, <i>The Plugs I Met</i> packs in as much lyrical weight that seven tracks can possibly hold, and yields 25 minutes of the most potent musical dope that 2019 offered up. &#8211; Michael Blair</span>
</p><p><strong>Released:</strong> June 21, 2019<br />
<strong>Label:</strong> Black Soprano Family, LLC<br />
<strong>Guests:</strong> Black Thought, Pusha-T, Jadakiss, Conway The Machine, 38 Spesh, RJ Payne<br />
<strong>Producers:</strong> Alchemist, Daringer, Beat Butcha, DJ Shay
<p class="p2" style="text-align: left;"><span class="s1"><br />
<strong>Big K.R.I.T. &#8211; <em>K.R.I.T. IZ HERE</em></strong></span>
</p><p><img class="size-full wp-image-97978 aligncenter" src="https://ambrosiaforheads.com/wp-content/uploads/2019/12/Krit_iz_here.jpeg" alt="" width="500" height="500" srcset="https://ambrosiaforheads.com/wp-content/uploads/2019/12/Krit_iz_here.jpeg 300w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/Krit_iz_here-150x150.jpeg 150w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/Krit_iz_here-100x100.jpeg 100w" sizes="(max-width: 500px) 100vw, 500px" />
<p class="p1" style="text-align: left;"><span class="s1">Big K.R.I.T. began this decade with a mixtape, <a href="https://www.livemixtapes.com/mixtapes/12049/krit_wuz_here.html" target="_blank" rel="noopener"><em>K.R.I.T. Wuz Here</em></a>, that stood as tall as that era&#8217;s best albums. To close out the 2010s, Krizzle finished strong with an LP that <a href="https://www.afhtv.com/big-k-r-i-t-describes-his-growth-as-an-artist-man-on-k-r-i-t-iz-here/videos/big-k-r-i-t-describes-the-evolution-experimentation-for-k-r-i-t-iz-here" target="_blank" rel="noopener">traces his growth and evolution</a> in <em><a href="https://open.spotify.com/album/1KvZT4NZm69EkOym8rLqW1?si=9jMhhsLFSo-68_JTArCKCQ" target="_blank" rel="noopener">K.R.I.T. IZ HERE</a>. </em>In both cases, King Remembered In Time leads the Rap pack. Rather than taking full control of the production and recording process on this go-round, the acclaimed double-threat focused almost solely on songwriting. Standout track <a href="https://ambrosiaforheads.com/2019/10/big-krit-mississippi-video/" target="_blank" rel="noopener">“M.I.S.S.I.S.S.I.P.P.I.”</a> is a dedication to his home state by acknowledging his upbringing while showing the enduring beauty of southern simplicity. Featuring one of his inspirations, Lil Wayne, <a href="https://ambrosiaforheads.com/2019/06/big-krit-lil-wayne-saweetie-song-audio/" target="_blank" rel="noopener">&#8220;Addiction&#8221;</a> looks at lust and love in the same light as lean and other vices. <a href="https://ambrosiaforheads.com/2019/07/big-krit-j-cole-song-audio/" target="_blank" rel="noopener">&#8220;Prove It,&#8221;</a> a reunion with J. Cole, shows two cult-lauded MC/producers who have become Hip-Hop front-runners through staying real with their fans. Balancing Funk, Hip-Hop, and old Soul, <em>K.R.I.T IZ Here</em> is about a man that can go to many different places when it comes to music. While handing production duties to Rico Love, DJ Khalil, and former Timbaland partner Danja, <a href="https://ambrosiaforheads.com/2018/01/big-krit-4eva-mighty-long-time-best-rap-album-2017-2/" target="_blank" rel="noopener">2017&#8217;s &#8220;Best Album&#8221; winner</a> uses his license to experiment with feel. However, he never loses sight of the sound that&#8217;s made him meaningful to so many, evident in opener <a href="https://ambrosiaforheads.com/2019/06/big-krit-iz-here-video/" target="_blank" rel="noopener">&#8220;K.R.I.T. Here&#8221;</a> and <a href="https://www.youtube.com/watch?v=LwM2k7f4Dfg" target="_blank" rel="noopener">&#8220;Believe.&#8221;</a>  K.R.I.T. began the decade as an underdog from the third coast underground. He enters 2020 with his own record company, a commitment to growth, and that same DIY spirit on an exponentially bigger stage. &#8211; Ms. Benzo</span>
</p><p><strong>Released:</strong> July 12, 2019<br />
<strong>Label:</strong> Multi Alumni/BMG<br />
<strong>Guests: </strong>Lil Wayne, Saweetie, Baby Rose, J.Cole, Yella Beezy, Rico Love<br />
<strong>Producers:</strong> (self), DJ Camper, Danja, Rico Love, Tariq Beats, Don Coleone, WOLFE de MCHLS, DJ Khalil, Musik Major X, Reuel Ethan, Luke Witherspoon, M Millz, Qkaution, Grant Strumwasser, Mike Hector, Wallis Lane, Ervin Garcia, Nabeyin, Uni, Rolynne Anderson, Tae Beast, Mark Byrd
<p class="p1" style="text-align: left;"><strong><span class="s1"><br />
Boogie &#8211;<i> Everythings For Sale<br />
</i></span></strong>
</p><p><img class="alignnone size-full wp-image-97973 aligncenter" src="https://ambrosiaforheads.com/wp-content/uploads/2019/12/boogie-everything.jpg" alt="" width="500" height="500" srcset="https://ambrosiaforheads.com/wp-content/uploads/2019/12/boogie-everything.jpg 1080w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/boogie-everything-150x150.jpg 150w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/boogie-everything-300x300.jpg 300w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/boogie-everything-768x768.jpg 768w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/boogie-everything-1024x1024.jpg 1024w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/boogie-everything-100x100.jpg 100w" sizes="(max-width: 500px) 100vw, 500px" />
</p><p>With three years of mixtape momentum, 30-year old Interscope Records MC/singer Boogie was <a href="https://ambrosiaforheads.com/2017/10/eminem-newest-artist-shady-griselda-cypher-video/" target="_blank" rel="noopener">added to Eminem&#8217;s Shady Records roster in late 2017</a>. For what might seem like an exciting and joyous chapter of Boogie’s career, <i><a href="https://open.spotify.com/album/14drLk9rMpA7GPk1MRvRE5?si=rCfZQp48S2Kaj0akw8LS9Q" target="_blank" rel="noopener">Everythings For Sale</a> </i>seems coated in quite the opposite emotion. Reflective and candid since 2014&#8217;s <em><a href="https://soundcloud.com/boogieofficial/sets/boogie-thirst-48-final" target="_blank" rel="noopener">Thirst 48</a></em>, Boogie’s scuffles with his own demons are amplified on the LP, as his popularity and access to temptation inflate. Largely centered around a turbulent relationship, the Compton-by-way-of-Long Beach native created a diary, assessing his infidelity (<a href="https://www.youtube.com/watch?v=TwPeCUivGCw" target="_blank" rel="noopener">“Silent Ride”</a>/<a href="https://www.youtube.com/watch?v=-ieBf24Z4IQ" target="_blank" rel="noopener">“Time”</a>/<a href="https://ambrosiaforheads.com/2019/02/eminem-boogie-rainy-days-video/" target="_blank" rel="noopener">“Rainy Days”</a>) and absence of self-worth (<a href="https://www.youtube.com/watch?v=p243tCuvAfY" target="_blank" rel="noopener">“Lolsmh”</a>/<a href="https://www.youtube.com/watch?v=A5oB9VQIsio" target="_blank" rel="noopener">“No Warning”</a>) from beginning to end. Clearly bothered by the same limelight that has brought him affluence (<a href="https://ambrosiaforheads.com/2019/01/boogie-jid-soho-video/">&#8220;Soho&#8221;</a>), Boogie’s most endearing quality is his self-awareness, as he remains deeply in-tune with his own toxic tendencies (<a href="https://www.youtube.com/watch?v=DXNMVRsIeB4" target="_blank" rel="noopener">“Self Destruction”</a>) throughout. Sincerity and blunt honesty prevail in the listen that also deals with fatherhood and failure. From a musical standpoint, there is no doubt that the versatile vocalist will flourish, as his beat selection, peer-backing, and <a href="https://ambrosiaforheads.com/2019/09/boogie-freestyle-buy-back-block/">lyrical cleverness</a> are exceptional and carry no expiration. With <i>Everything’s For Sale</i> as confirmation, the sobering yet refreshingly truthful story of Boogie will unfold right alongside his inevitably prosperous career ahead. &#8211; Michael Blair<br />
<span class="s1"><strong>Released:</strong> January 25, 2019<br />
<strong>Label:</strong> Shady/Interscope Records<br />
<strong>Guests:</strong> Eminem, J.I.D., 6LACK, Snoah Aalegra, Shae Universe, Christian Scott aTunde Adjuah<br />
<strong>Producers:</strong> Eminem, Keyel, Ryan Feinberg, Dart, Ashton McCreight, C. Ballin, Chris McCleaney, Fresh Ayr, James Teej, Mario Luciano, Nabeyin, Symbolyc One, Streetrunner</span>
<p style="text-align: left;"><strong><br />
Dreamville &#8211; <em>Revenge Of The Dreamers III</em></strong>
</p><p><img class="aligncenter size-full wp-image-97354" src="https://ambrosiaforheads.com/wp-content/uploads/2019/11/Revenge-of-the-Dreamers-3.jpg" alt="" width="500" height="500" srcset="https://ambrosiaforheads.com/wp-content/uploads/2019/11/Revenge-of-the-Dreamers-3.jpg 640w, https://ambrosiaforheads.com/wp-content/uploads/2019/11/Revenge-of-the-Dreamers-3-150x150.jpg 150w, https://ambrosiaforheads.com/wp-content/uploads/2019/11/Revenge-of-the-Dreamers-3-300x300.jpg 300w, https://ambrosiaforheads.com/wp-content/uploads/2019/11/Revenge-of-the-Dreamers-3-100x100.jpg 100w" sizes="(max-width: 500px) 100vw, 500px" />
</p><p>When the Dreamville squad invited over 300 producers and rappers to attend a 10-day recording session at Tree Sounds Studios in the Atlanta suburbs, it seemed like a Hip-Hop fantasy camp–especially to kick-off 2019. <a href="https://open.spotify.com/album/2n3quCZ0anEa46j2IveacI?si=ZNknpk-dTNe_O5QMzGjU-w" target="_blank" rel="noopener"><em>Revenge Of The Dreamers III</em></a> promised to be a time capsule that showed off the label roster—founder J. Cole, Ari Lennox, Bas, Cozz, Omen, Lute, J.I.D., and EarthGang. That had been the case with the previous two volumes. However, this team, it mixed the &#8216;Ville talents with a cross-section of hand-picked artists and producers. DaBaby, Smino, Maxo Kream, Key!, Vince Staples, Guapdad 4000, T.I., Young Nudy, Buddy, and so many others joined the party, which eventually yielded to just 18 tracks. The end result is a diverse compilation album deserving of critical praise and multiple playbacks. <a href="https://ambrosiaforheads.com/2019/09/jcole-lute-dababy-under-the-sun-video/" target="_blank" rel="noopener">&#8220;Under The Sun&#8221;</a> sees three North Carolina natives, J. Cole, Lute, and DaBaby, spit over a Soul-soaked beat and between an uncredited hook by Kendrick Lamar. <a href="https://www.youtube.com/watch?v=H_0ZEHNbZbk" target="_blank" rel="noopener">&#8220;Ladies, Ladies, Ladies&#8221;</a> pairs the silky-spitter J.I.D. with T.I. for a clever and smooth interpolation of <a href="https://www.youtube.com/watch?v=j7-B1ru5U-I" target="_blank" rel="noopener">JAY-Z&#8217;s &#8220;Girls, Girls Girls.&#8221;</a> <a href="https://ambrosiaforheads.com/2019/08/earthgang-saba-smino-j-cole-sacrifices-video/" target="_blank" rel="noopener">&#8220;Sacrifices&#8221;</a> gives EARTHGANG, Cole, and Smino a warm and beautifully sweet song that shares an equal range of excitement and bellowing vocals. <a href="https://ambrosiaforheads.com/2019/06/j-cole-revenge-dreamers-rotd3-bas-jid-down/" target="_blank" rel="noopener">&#8220;Down Bad&#8221;</a> sees Bas, J.I.D., and Cole flexing on the competition to a beat that feels like a 2019 take on Bomb Squad production. If label compilations felt like a thing of the 1990s, J. Cole and Dreamville reinvigorated them with creativity, chemistry, and a campaign to crown Hip-Hop&#8217;s new reigning imprint &#8211; Kevin Cortez
</p><p><strong>Released</strong>: July 5, 2019<br />
<strong>Label</strong>: Dreamville/Interscope<br />
<strong>Guests</strong>: J. Cole, DaBaby, Lute, Vince Staples, Young Nudy, Bas, EarthGang (Olu &amp; Wow Gr8), J.I.D., Childish Major, Cozz, Reason, Zoink Gang, Key!, Maxo Kream, Yung Baby Tate, Guapdad 4000, Buddy, Omen, Mez, DaVionne, Ari Lennox, Baby Rose, T.I., Reese Laflare, Jace, Smokepurpp, Ski Mask the Slump God, Smino, Ty Dolla $ign, Dreezy, Mereba, Deante&#8217; Hitchcock, St. Beauty, Saba<br />
<strong>Producers</strong>: J. Cole, Ibrahim Hamad, Archer, Bink!, Bizness Boi, Cam O&#8217;bi, ChaseTheMoney, Christo, ClickNPress, Cubeatz, Deputy, E. Dan, Elite, Galimatias, Groove Chambers, Henny Tha Bizness, Hollywood JB, Jay Kurzweil, Kenneth Harris, Kal Banx, Keanu Beats, Lil&#8217;A, Meez, MD Beatz, Nice Rec, Nxstalgic, OZ, Pluss, Pyrex, Ron Gilmore, Sensei Bueno, T-Minus
</p><p><strong>EARTHGANG &#8211; <em>Mirrorland</em></strong>
</p><p>&nbsp;
<div><img class="size-full wp-image-98115 aligncenter" src="https://ambrosiaforheads.com/wp-content/uploads/2019/12/OIP.IDf5FTftQDSXhOEraD-njAHaHa.jpeg" alt="" width="500" height="500" srcset="https://ambrosiaforheads.com/wp-content/uploads/2019/12/OIP.IDf5FTftQDSXhOEraD-njAHaHa.jpeg 474w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/OIP.IDf5FTftQDSXhOEraD-njAHaHa-150x150.jpeg 150w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/OIP.IDf5FTftQDSXhOEraD-njAHaHa-300x300.jpeg 300w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/OIP.IDf5FTftQDSXhOEraD-njAHaHa-100x100.jpeg 100w" sizes="(max-width: 500px) 100vw, 500px" /></div>
</p><p>Inspired by Quincy Jones&#8217; score for the Broadway musical, <a href="https://pitchfork.com/features/rising/earthgang-interview-mirrorland/" target="_blank" rel="noopener"><em>The Wiz</em></a>, EARTHGANG ushered in their first full-length LP, <a href="https://open.spotify.com/album/2JtlTPzThXs3Pvz8V2iBIB" target="_blank" rel="noopener"><em>Mirrorland</em></a>. The record as a whole captures the ear with a whimsical sound and spirit as felt on cuts including, <a href="https://www.youtube.com/watch?v=1yU2NRW47_o" target="_blank" rel="noopener">&#8220;LaLa Challenge,&#8221;</a> while tracks like the T-Pain-assisted, <a href="https://www.youtube.com/watch?v=kILlO21yTl4" target="_blank" rel="noopener">&#8220;Tequila,&#8221;</a> transport listeners to other ends of the world. Throughout, Johnny Venus and Doctor Dot&#8217;s skills behind the microphone fly uniquely far beyond the art of rapping, elevating their deft musicianship with innovative inflections, crooning, cadences, and tone to harmoniously captivate their expanding audience. In conjunction with the MCs&#8217; inventive stretches in sound, the Atlanta, Georgia artists&#8217; storytelling abilities are equally as potent from beginning to end. The dark and crawling emotion of their single, <a href="https://www.youtube.com/watch?v=IzTHK7F7CjQ" target="_blank" rel="noopener">&#8220;Swivel,&#8221;</a> lyrically captures the rappers&#8217; past pain and desperation, while singles like the Young Thug-assisted, <a href="https://www.youtube.com/watch?v=S2qjSbdtFJY" target="_blank" rel="noopener">&#8220;Proud Of U,&#8221;</a> juxtapose one another with tales bubbling in bliss and vivacity. Following the <a href="https://ambrosiaforheads.com/2017/04/jid-freestyle-king-of-the-south-video/" target="_blank" rel="noopener">success of Spillage Village band-mate (and Dreamville label-mate)  J.I.D.</a>, it is now time for Dot and Johnny to get all the props. Overall, EARTHGANG&#8217;s inauguration into the game&#8217;s upper echelon is reflective of their passion for their craft and willingness to explore uncharted musical waters. &#8211; Jacob &#8220;34&#8221; Koertge
<p style="text-align: left;"><strong>Released</strong>: September 6, 2019<br />
<strong>Label</strong>: Dreamville / Interscope / Spillage Village<br />
<strong>Guests</strong>: Young Thug, T-Pain, Kehlani, Arin Ray, Malik<br />
<strong>Producers</strong>: Lido, Olu, J. Cole, VOU, Edsclusive, Childish Major, Big Korey, Ant Chambers, Natra Average, Bink!, DJ Dahi, Ron Gilmore, Elite, Pete Nebula, Groove, Christo, Elite, Brian Malik Baptiste, DJ Khalil, Rahki, D.K. the Punisher, Dre
</p><p><strong>Gang Starr &#8211; <em>One Of The Best Yet</em></strong>
</p><p><img class="alignnone size-full wp-image-98119" src="https://ambrosiaforheads.com/wp-content/uploads/2019/12/gang-starr-one-of-the-best-yet-album-artwork.jpg" alt="" width="500" height="500" srcset="https://ambrosiaforheads.com/wp-content/uploads/2019/12/gang-starr-one-of-the-best-yet-album-artwork.jpg 500w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/gang-starr-one-of-the-best-yet-album-artwork-150x150.jpg 150w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/gang-starr-one-of-the-best-yet-album-artwork-300x300.jpg 300w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/gang-starr-one-of-the-best-yet-album-artwork-100x100.jpg 100w" sizes="(max-width: 500px) 100vw, 500px" />
<p class="p1"><span class="s1">Over 15 years since the iconic duo’s last release, and nearly a decade since the passing of Guru, Gang Starr resurfaced with <a href="https://ambrosiaforheads.com/2019/11/gangstarr-one-of-the-best-yet-album-stream-audio/" target="_blank" rel="noopener"><em>One Of The Best Yet</em></a>, the seventh full-length album in the pair’s historical 30-year campaign. While posthumous releases can oftentimes bear a stale and disconnected undercurrent, DJ Premier ingrained the spirit of Guru so tightly within this effort’s fabric. It is as if Baldhead Slick was still in the flesh, blessing the mic. Entirely produced by the legendary Preemo, it took him (along with Guru&#8217;s estate) sparring with Solar <a href="https://ambrosiaforheads.com/2019/10/gangstarr-album-dj-premier-guru-solar/">(a later collaborator of Guru’s)</a> to obtain the rights to unreleased vocals that eventually became the foundation of this project. Part philosopher and part lyrical executioner, the unearthing of Guru’s buried words act as a grand testimony to his technique and impact transcending the test of time. These are evident in video singles such as <a href="https://ambrosiaforheads.com/2019/10/gangstarr-jcole-family-loyalty-video/" target="_blank" rel="noopener">&#8220;Family And Loyalty&#8221;</a> and <a href="https://ambrosiaforheads.com/2019/11/gangstarr-guru-son-dj-premier-video/" target="_blank" rel="noopener">&#8220;Bad Name.&#8221;</a> <em>One Of The Best Yet</em> also serves as a refreshing marriage between the then and now, with the elected features of contemporaries (Q-Tip), family members (Jeru, Group Home, M.O.P., etc.)  and modern heavyweights (J. Cole, Royce, Talib) seamlessly blending distant eras. While closure wasn’t necessary in regards to Gang Starr’s standing within the history books, <em>One Of The Best Yet</em> does allow for a warmer and more triumphant conclusion to an otherwise magnificent tale of Hip-Hop supremacy. </span><span class="s1">As Preemo’s renowned cuts have suggested throughout the duo&#8217;s existence, we&#8217;ve been &#8220;<em>rocking with the best</em>&#8221; for three decades now. What a true gift it is for the Hip-Hop faithful to have the pleasure of doing so with new Gang Starr, <a href="https://ambrosiaforheads.com/2019/10/gangstarr-album-dj-premier-guru-solar/" target="_blank" rel="noopener">at least</a> one more time. &#8211; Michael Blair</span>
<p style="text-align: left;"><span class="s1"><strong>Released:</strong> November 1, 2019<br />
<strong>Label:</strong> Gang Starr Enterprises/To The Top<br />
<strong>Guests:</strong> Q-Tip, M.O.P. (Billy Danze &amp; Lil Fame), Royce 5’9, Jeru The Damaja, J. Cole, Talib Kweli, Ne-Yo, Nitty Scott, Big Shug, Freddie Foxxx, Group Home (Lil Dap &amp; Melachi The Nutcracker)<br />
<strong>Producer:</strong> self</span>
</p><p><strong>Griselda &#8211; <em>WWCD (What Would &#8216;Chine Do)</em></strong>
</p><p><img class="size-full wp-image-98114 aligncenter" src="https://ambrosiaforheads.com/wp-content/uploads/2019/12/Griselda-Wwcd.jpg" alt="" width="500" height="500" srcset="https://ambrosiaforheads.com/wp-content/uploads/2019/12/Griselda-Wwcd.jpg 500w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/Griselda-Wwcd-150x150.jpg 150w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/Griselda-Wwcd-300x300.jpg 300w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/Griselda-Wwcd-100x100.jpg 100w" sizes="(max-width: 500px) 100vw, 500px" />
</p><p>When Eminem signed <a href="https://ambrosiaforheads.com/2017/03/eminem-signs-westside-gunn-conway-the-machine-shady/" target="_blank" rel="noopener">Westside Gunn, Conway The Machine</a>, and <a href="https://ambrosiaforheads.com/2019/04/griselda-westside-gunn-conway-benny-group-album-shady/" target="_blank" rel="noopener">Benny The Butcher</a> to Shady Records two and half years ago, the label collective was already at the forefront of a grimy, hustle-Rap renaissance. However, in recent years, highly-impressive solo work from <a href="https://ambrosiaforheads.com/2018/12/best-album-2018-pusha-t-westside-gunn/" target="_blank" rel="noopener">Wes&#8217;</a>, <a href="https://ambrosiaforheads.com/2019/01/conway-the-machine-alchemist-video/" target="_blank" rel="noopener">Conway</a>, and <a href="https://ambrosiaforheads.com/2018/11/benny-the-butcher-daringer-joe-pesci-38-video/" target="_blank" rel="noopener">Benny</a> propelled them to the forefront of who&#8217;s next in Hip-Hop. <em><a href="https://ambrosiaforheads.com/2019/11/griselda-shady-album-westside-benny-conway-stream-video/" target="_blank" rel="noopener">WWCD</a>, </em>named after their deceased relative and rapper, Machine Gun Black, honors tradition while taking things to the highest level yet. This 13-track offering is a distillation of everything fans love about Griselda: savvy deliveries, hard Daringer beats (alongside Beat Butcha), and raw street content. Despite some of the most coveted backing in Rap, the album sounds like it could&#8217;ve been any number of the Griselda releases in the 2010s. However, it finds three Buffalo, New York MCs at the top of their game. Debut single <a href="https://ambrosiaforheads.com/2019/10/griselda-benny-conway-westside-shady-song/" target="_blank" rel="noopener">“DR. BIRD&#8217;S”</a> is trademark GxFR, as is <a href="https://www.youtube.com/channel/UCMd41AKqQhGVyEdQAjnzFUg" target="_blank" rel="noopener">&#8220;Moselle.&#8221;</a> For those paying attention, this brick-by-brick movement dates back more than a decade. However, just like Eminem 20 years ago, Griselda represents a new underground dream come true. Without compromise, this brand of Rap carries the torch for so many Hip-Hop luminaries. &#8211; Jordan Commandeur
</p><p><strong>Released:</strong> November 29, 2019<br />
<strong>Label:</strong> Griselda/Shady Records<br />
<strong>Guests:</strong> Novel, Tiona Denice, Keisha Plum, 50 Cent, AA Rashid, Eminem, Raekwon<br />
<strong>Producer:</strong> Daringer, Beat Butcha
<p style="text-align: left;"><strong><br />
Freddie Gibbs &amp; Madlib &#8211; <em>Bandana</em></strong>
</p><p><img class="aligncenter size-full wp-image-97243" src="https://ambrosiaforheads.com/wp-content/uploads/2019/11/Freddie-Gibbs-Madlib-Bandana.jpg" alt="" width="500" height="500" srcset="https://ambrosiaforheads.com/wp-content/uploads/2019/11/Freddie-Gibbs-Madlib-Bandana.jpg 600w, https://ambrosiaforheads.com/wp-content/uploads/2019/11/Freddie-Gibbs-Madlib-Bandana-150x150.jpg 150w, https://ambrosiaforheads.com/wp-content/uploads/2019/11/Freddie-Gibbs-Madlib-Bandana-300x300.jpg 300w, https://ambrosiaforheads.com/wp-content/uploads/2019/11/Freddie-Gibbs-Madlib-Bandana-100x100.jpg 100w" sizes="(max-width: 500px) 100vw, 500px" />
</p><p>Freddie Gibbs &amp; Madlib&#8217;s latest entry in their <a href="https://ambrosiaforheads.com/2016/05/freddie-gibbs-madlib-announce-sophomore-collabo-album/" target="_blank" rel="noopener">collaboration trilogy</a>, <em>Bandana</em>, plays out like a fine piece of cinema. Five years removed from <a href="https://open.spotify.com/album/43uErencdmuTRFZPG3zXL1?si=J8dWsi-XS7a7UTw-l7NC8A" target="_blank" rel="noopener"><em>Piñata</em></a>, the &#8220;Freddie Caine&#8221; character is a reformed drug kingpin, at least at the surface. In a Hip-Hop adaptation of <em>Carlito&#8217;s Way</em>, he wants the straight path, but the underbelly of his past won&#8217;t let him chill. Although a comedic portrayal in the LP&#8217;s music videos, the character&#8217;s lyrics are reinforced with Gibbs&#8217; uncompromising stories from his life outside of Rap. He deploys the tales using various flows, sometimes jack-hammering his words into the sample-based beats. Madlib, whose soulful production (reportedly made on an iPad) creates a visual mood for Freddie Gibbs to showcase his criminal escapades within. As always, Otis Jackson, Jr. walks the line between film score and Hip-Hop through his own controlled chaos. Gibbs paints a picture of the success he&#8217;s achieved through an underworld of drugs on <a href="https://ambrosiaforheads.com/2019/05/freddie-gibbs-madlib-bandana-video/" target="_blank" rel="noopener">&#8220;Crime Pays.&#8221;</a> He spits candidly of a secret love affair with <a href="https://www.youtube.com/watch?v=_4lXmmrw7gI" target="_blank" rel="noopener">&#8220;Practice.&#8221;</a> The MC also reflects on how murder affects a person&#8217;s sanity on <a href="https://www.youtube.com/watch?v=MmvzeR2AFhA" target="_blank" rel="noopener">&#8220;Fake Names.&#8221;</a> The features may be even more exciting, from Anderson .Paak&#8217;s powerful impression on<a href="https://ambrosiaforheads.com/2019/07/freddie-gibbs-madlib-giannis-video/" target="_blank" rel="noopener"> &#8220;Giannis,&#8221;</a> to stellar appearances from Killer Mike, Pusha-T, Yasiin Bey, and Black Thought on <a href="https://www.youtube.com/watch?v=NSn_r2w-idg" target="_blank" rel="noopener">&#8220;Palmolive&#8221;</a> and <a href="https://ambrosiaforheads.com/2019/06/black-thought-yasiin-bey-freddie-gibbs-educate-by-any-means-over-madlib-production/" target="_blank" rel="noopener">&#8220;Education,&#8221;</a> divided respectively. Packaged with skits, obscure Soul samples, and flawless transitions, <em>Bandana</em> feels at home with other recent Gangsta Rap releases, yet unconcerned with competition of any kind. &#8211; Kevin Cortez
</p><p><strong>Released</strong>: June 28, 2019<br />
<strong>Label</strong>: Keep Cool/RCA Records<br />
<strong>Guests</strong>: Killer Mike, Pusha-T, Anderson .Paak, Yasiin Bey, Black Thought<br />
<strong>Producers</strong>: self
</p><p><strong>Little Brother &#8211; <em>May The Lord Watch</em></strong>
</p><p><img class="aligncenter size-full wp-image-97244" src="https://ambrosiaforheads.com/wp-content/uploads/2019/11/Little-Brother-May-the-Lord-Watch.jpg" alt="" width="500" height="500" srcset="https://ambrosiaforheads.com/wp-content/uploads/2019/11/Little-Brother-May-the-Lord-Watch.jpg 500w, https://ambrosiaforheads.com/wp-content/uploads/2019/11/Little-Brother-May-the-Lord-Watch-150x150.jpg 150w, https://ambrosiaforheads.com/wp-content/uploads/2019/11/Little-Brother-May-the-Lord-Watch-300x300.jpg 300w, https://ambrosiaforheads.com/wp-content/uploads/2019/11/Little-Brother-May-the-Lord-Watch-100x100.jpg 100w" sizes="(max-width: 500px) 100vw, 500px" />
</p><p>After more than <a href="https://ambrosiaforheads.com/2019/08/watch-a-video-that-details-the-events-leading-up-to-little-brothers-2018-reunion/" target="_blank" rel="noopener">eight years of separation</a> and giving fans <a href="https://ambrosiaforheads.com/2019/08/little-brother-mtlw-may-album-title-artwork/" target="_blank" rel="noopener">less than 24 hours of notice</a>, Little Brother reunited this year and released one of the best albums in its touted catalog. <a href="https://ambrosiaforheads.com/2019/08/little-brother-mtlw-may-album-title-artwork/" target="_blank" rel="noopener"><em>May The Lord Watch</em></a> sees Phonte and Rapper Big Pooh reviving the L.B. brand with conscious bars that acknowledge the past, while still keeping tensions comfortably (and maturely) in the rearview. With <a href="https://www.youtube.com/watch?v=LwULNaJ3h8g" target="_blank" rel="noopener">&#8220;Right On Time,&#8221;</a> both artists describe the stresses and sacrifices of trying to make it in music. Pooh recalls his time as an Uber driver to supplement his lulls in his indie entertainment career, while Phonte vents on the pressures he faces to balance being a great artist and family provider at once. Video single <a href="https://ambrosiaforheads.com/2019/08/little-brother-black-magic-video/" target="_blank" rel="noopener">&#8220;Black Magic (Make It Better),&#8221;</a> Phonte and Pooh celebrate the power of their skin and L.B.&#8217;s all-time knack to be authentic rappers and human beings. Interlaced between each bouncy, snappy beat provided by producers like Nottz, Khrysis, and Focus&#8230; are hilarious skits that honor their 2005 classic album, <a href="https://ambrosiaforheads.com/2015/09/on-its-10-year-anniversary-little-brother-remembers-the-minstrel-show-with-new-perspective/" target="_blank" rel="noopener"><em>The Minstrel Show</em></a>. Hip-Hop has changed in 15 years, and so has Little Brother. However, <em>May The Lord Watch</em> finds the thread between then and now. Unconcerned with modernization, but never pandering for nostalgia, Little Brother has created a stellar comeback record full of the humor, self-awareness, and sincerity. This duo seamlessly fills the void they left behind with rhymes, beats, and life. &#8211; Kevin Cortez
<p style="text-align: left;"><strong>Released</strong>: August 20, 2019<br />
<strong>Label</strong>: Imagination Nation/For Members Only/EMPIRE<br />
<strong>Guests</strong>: Peter Rosenberg, Questlove, Darien Brockington, Madison McFerrin, Tamisha Waden, Joe Scudda, Carlitta Durand, Blakk Soul, BeMyFiasco<br />
<strong>Producers</strong>: Khrysis, Nottz, Focus&#8230;, Black Milk, King Michael Coy, Blaaq Gold
</p><p><strong>Murs, 9th Wonder And The Soul Council &#8211; <em>The Iliad Is Dead And The Odyssey Is Over</em></strong>
</p><p><img class="size-full wp-image-97980 aligncenter" src="https://ambrosiaforheads.com/wp-content/uploads/2019/12/murs-9th-iliad-dead-700.jpg" alt="" width="500" height="500" srcset="https://ambrosiaforheads.com/wp-content/uploads/2019/12/murs-9th-iliad-dead-700.jpg 700w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/murs-9th-iliad-dead-700-150x150.jpg 150w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/murs-9th-iliad-dead-700-300x300.jpg 300w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/murs-9th-iliad-dead-700-100x100.jpg 100w" sizes="(max-width: 500px) 100vw, 500px" />
</p><p>Ever since he first burst on the scene with the Living Legends in the mid-1990s, Murs has stood out from the pack. The Los Angeles, California journeyman has made an impact with a plethora of labels and crews, morphing from underground road warrior to an MC hiring Snoop Dogg and DJ Quik to work on major label LPs. However, in a sprawling discography that includes side-projects like Felt, The White Mandingos, MURSDAY!, Murray&#8217;s music with 9th Wonder has been some of the best and most definitive of his career. <a href="https://open.spotify.com/album/7gY2JVughebK1borXe7h8J?si=SOYV-gQuQ0-09CGubKqzyg" target="_blank" rel="noopener"><em>The Iliad Is Dead And The Odyssey Is Over</em></a> is buoyed by powerful and poignant songs like <a href="https://www.youtube.com/watch?v=Xd3_9I8Sxsw" target="_blank" rel="noopener">“My Hero,”</a> which details the harsh reality of a sex worker and <a href="https://www.youtube.com/watch?v=hTfC5dQJZU8" target="_blank" rel="noopener">“Tony Robbins Pocketbook,”</a> a song that is equal parts self-affirmation and invaluable advice. Other highlights include Murs&#8217; candid relationship songs <a href="https://www.youtube.com/watch?v=OuaUGwS9_RI" target="_blank" rel="noopener">“Give Me A Reason,”</a> <a href="https://www.youtube.com/watch?v=EehpsLEOaJM" target="_blank" rel="noopener">“F*ck Them,”</a> and a heavy cut that tells a cautionary tale about an extra-marital affair, <a href="https://www.youtube.com/watch?v=E1N31DWuq8w" target="_blank" rel="noopener">“SIN.”</a> Although Murs and 9th have said it before, this is rumored to be the last stop on the line. After approximately 75 songs together, Murs and 9th made plenty of great songs in the 15 years since <em><a href="https://open.spotify.com/album/73P9PjA8US77r5NoAr9Qul?si=0kRyPcc7RX69iH4mFCDrFw" target="_blank" rel="noopener">Murs 3:16: The 9th Edition</a></em>. However, the two albums that bookend this cross-country relationship may be the finest. &#8211; Jordan Commandeur
<p style="text-align: left;"><strong>Released:</strong> August 9, 2019<br />
<strong>Label:</strong> Murs 316/Jamla/EMPIRE<br />
<strong>Guests:</strong> GQ, Heather Victoria, Pookie Blow, Rapsody, Reuben Vincent, $ilkMoney, URLACOJO<br />
<strong>Producers: </strong>self, The Soul Council (Kash, Khrysis, Eric G, Nottz), JDEAFBEATS
</p><p><strong>Rapsody &#8211; <em>Eve</em></strong>
</p><p><img class="size-full wp-image-97974 aligncenter" src="https://ambrosiaforheads.com/wp-content/uploads/2019/12/7b25c4c5d6c4d9f1a1158c277a4fa31e.750x750x1.jpg" alt="" width="500" height="500" srcset="https://ambrosiaforheads.com/wp-content/uploads/2019/12/7b25c4c5d6c4d9f1a1158c277a4fa31e.750x750x1.jpg 750w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/7b25c4c5d6c4d9f1a1158c277a4fa31e.750x750x1-150x150.jpg 150w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/7b25c4c5d6c4d9f1a1158c277a4fa31e.750x750x1-300x300.jpg 300w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/7b25c4c5d6c4d9f1a1158c277a4fa31e.750x750x1-100x100.jpg 100w" sizes="(max-width: 500px) 100vw, 500px" />
</p><p>It&#8217;s been said many times before, but this year was a tremendous year for women in Hip-Hop. From Megan Thee Stallion&#8217;s &#8220;Hot Girl Summer&#8221; campaign to <a href="https://abcnews.go.com/US/wireStory/queen-latifah-receive-harvard-black-culture-award-66249317" target="_blank" rel="noopener">Queen Latifah&#8217;s Harvard University Award</a> and Missy Elliott&#8217;s <a href="https://ambrosiaforheads.com/2019/08/missy-elliott-videos-vma-speech/" target="_blank" rel="noopener">Video Vanguard performance</a>, women in Rap made history on and off the charts. Rapsody placed herself firmly at the head of the table with the August release of <em><a href="https://ambrosiaforheads.com/2019/09/rapsody-eve-album-review/" target="_blank" rel="noopener">Eve</a>, </em>the follow-up to her Grammy-nominated 2017 album <a href="https://open.spotify.com/album/0IkioqpdjITJwhbRliLoCx?si=FO--pSOPRkOdUsINRfEvmQ" target="_blank" rel="noopener"><em>Laila&#8217;s Wisdom</em></a>. The Snow Hill, North Carolina MC is a veteran who got her start rapping as a member of Kooley High back in the 2000s, but for many <em>Eve </em>signaled her overdue acknowledgment as one of the best rappers out today, period. She did it with a serious devotion to Black femininity, choosing to title each track after her heroes, all of whom are women of color. She celebrates financial independence alongside Leikeli47 on <a href="https://www.youtube.com/watch?v=UTrIB5MabS8" target="_blank" rel="noopener">&#8220;Oprah,&#8221;</a> honors her Hip-Hop forefathers and foremothers with GZA and D&#8217;Angelo on <a href="https://ambrosiaforheads.com/2019/08/rapsody-gza-dangelo-9th-wonder-liquid-swords/" target="_blank" rel="noopener">&#8220;Ibtihaj,&#8221;</a> and triumphs the women who&#8217;ve helped her along the way with Queen Latifah on <a href="https://ambrosiaforheads.com/2019/08/rapsody-queen-latifah-hatshepsut-nottz-audio-playlist/" target="_blank" rel="noopener">&#8220;Hatshepsut.&#8221;</a> Together with her Jamla family including 9th Wonder and Khrysis, Rapsody released a monumental piece of work that coupled discussions about undeniable lyrical talent with love letters to Black women, reminding us with the album&#8217;s title that we all come from the same, original Black woman hundreds of thousands of of years ago. And for those who may have missed the unfettered bars she spits all over the album, it only takes one spin of the opening track, <a href="https://www.youtube.com/watch?v=54yOD994ors" target="_blank" rel="noopener">&#8220;Nina,&#8221;</a> to be reminded that Rapsody isn&#8217;t hiding behind a high-brow concept album nor satisfied with being known only as the best <em>female </em>rapper: &#8220;<em>Know I&#8217;m a God MC, &#8217;cause ni**a, I made the devil wait</em>.&#8221; &#8211; Amanda Mester
</p><p><strong>Released</strong>: August 23, 2019<br />
<strong>Label</strong>: Jamla/Roc Nation<br />
<strong>Guests</strong>: Leikeli47, K. Roosevelt, GZA, D&#8217;Angelo, Mereba, Elle Varner, SiR, J.I.D, Queen Latifah, J. Cole, PJ Morton<br />
<strong>Producers</strong>: The Soul Council, (9th Wonder, Eric G, Khrysis &amp; Nottz), Mark Byrd
<p style="text-align: left;"><strong><br />
Skyzoo &amp; Pete Rock &#8211; <em>Retropolitan</em></strong>
</p><p><img class="size-full wp-image-97975 aligncenter" src="https://ambrosiaforheads.com/wp-content/uploads/2019/12/th.jpg" alt="" width="500" height="500" srcset="https://ambrosiaforheads.com/wp-content/uploads/2019/12/th.jpg 474w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/th-150x150.jpg 150w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/th-300x300.jpg 300w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/th-100x100.jpg 100w" sizes="(max-width: 500px) 100vw, 500px" />
</p><p>Together with legendary producer Pete Rock, Brooklyn, New York MC Skyzoo penned a tribute to the New York City of yesterday and tomorrow in <a href="https://ambrosiaforheads.com/2019/09/skyzoo-pete-rock-retropolitan-interview-video/" target="_blank" rel="noopener"><em>Retropolitan</em></a>. Featuring verses from Styles P, Westside Gunn, Conway The Machine, Benny The Butcher and Elzhi, the September release arrived just in time for cooler weather. The collaborative effort is a postcard from Hip-Hop&#8217;s birthplace, filled with S-K-Y&#8217;s reflections of life on his old block and the ways in which the city is changing. Pete and Sky&#8217; set the conceptual tone with the artwork for the album&#8217;s lead single, <a href="https://ambrosiaforheads.com/2019/08/pete-rock-skyzoo-retropolitan-single-features/" target="_blank" rel="noopener">&#8220;It&#8217;s All Good,&#8221;</a> which paired a mural honoring a Black victim of police violence from decades ago with a foreground of NY&#8217;s modern-day bike-share system. Throughout the 12-track Mello Music Group release, Sky; recalls the golden age of coming up in a time when &#8220;<em>my whole block was in Penny jerseys</em>&#8221; while lamenting the stranglehold of gentrification that led him to see &#8220;<em>spots get turned to croissant sellers</em>.&#8221; On <a href="https://ambrosiaforheads.com/2019/09/skyzoo-pete-rock-truck-jewels-audio-premiere/" target="_blank" rel="noopener">&#8220;Truck Jewels,&#8221;</a> Heads were treated to a rare gem in the form of a Rap verse from P.R. which includes the quote-worthy &#8220;<em>Me fallin’ off is like a Muslim at a luau.</em>&#8221; The First Generation Rich founder carries the overwhelming majority of the album&#8217;s lyrical content on his own two (and, because he&#8217;s Skyzoo, he does it breathlessly). But on <a href="https://ambrosiaforheads.com/2019/09/skyzoo-elzhi-griselda-pete-rock-song/" target="_blank" rel="noopener">&#8220;Eastern Conference All-Stars,&#8221;</a> a truly insane amount of lyricism packed itself into fewer than six minutes, with Conway, Benny, Westside Gunn and Elzhi joining Sky for 2019&#8217;s posse cut of the year. &#8211; Amanda Mester
<p style="text-align: left;"><strong>Released</strong>: September 20, 2019<br />
<strong>Label</strong>: Mello Music Group<br />
<strong>Guests</strong>: Benny The Butcher, Westside Gunn, Conway The Machine, Elzhi, Styles P, Raheem DeVaughn<br />
<strong>Producers</strong>: self
</p><p><strong>Smif-N-Wessun &#8211; <em>The All</em></strong>
</p><p><img class="size-full wp-image-97976 aligncenter" src="https://ambrosiaforheads.com/wp-content/uploads/2019/12/Smif-N-Wessun-The-All.jpg" alt="" width="500" height="500" srcset="https://ambrosiaforheads.com/wp-content/uploads/2019/12/Smif-N-Wessun-The-All.jpg 500w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/Smif-N-Wessun-The-All-150x150.jpg 150w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/Smif-N-Wessun-The-All-300x300.jpg 300w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/Smif-N-Wessun-The-All-100x100.jpg 100w" sizes="(max-width: 500px) 100vw, 500px" />
</p><p>“<em>They said, ‘Take ’em back to <a href="https://open.spotify.com/album/0TaYPOKCUDyvZU2APQ7kPM?si=Ahzsl--DRtWb-T43WOcP-w" target="_blank" rel="noopener">Dah Shinin’</a>,’ but they don’t know the shape that my mind’s in,</em>” Tek says under oath on <a href="https://ambrosiaforheads.com/2019/01/smif-n-wessun-the-all-testify-video/" target="_blank" rel="noopener">“Testify,”</a> a nod to Smif-N-Wessun&#8217;s influential 1995 debut. “<em>The game’s different and my man’s gone,</em>” he continues, noting the passing of fellow Boot Camp Clik member Sean Price. Whether intentional or a matter of circumstance, on an album characterized by progression, it’s almost appropriate that <a href="https://open.spotify.com/album/5wDGT0JMLKKpOmttJyhPA2?si=EqookG3oQl-hkh-eQOZHiw" target="_blank" rel="noopener"><em>The All</em></a> doesn&#8217;t feature a posthumous verse from S-N-W&#8217;s fallen protégé. Instead, Tek and Steele pay their respects in remembrance of their lost brother personally, referencing him or his former group Heltah Skeltah at least half a dozen times throughout the concise 12-track LP. With 9th Wonder and his Soul Council team at the helm, providing dynamic, multi-layered beats rooted by hard-hitting drums, the seasoned “<em>rappin’ dudes</em>” guide listeners on a biographical journey through their Bucktown upbringing and remind heads of their many contributions to the culture. The Brooklyn O.G.&#8217;s do so without sounding bitter, self-indulgent, or out of touch. Songs like <a href="https://www.youtube.com/watch?v=8lIv-_JRv8c" target="_blank" rel="noopener">“Dreamland”</a> featuring Raekwon and Jamla songstress Heather Victoria or <a href="https://www.youtube.com/watch?v=qHrNw-N2T7s" target="_blank" rel="noopener">“Letter 4 U,”</a> on which they pen vulnerable verses for various loved ones, offer glimpses into their personal lives. Others are more self-congratulatory, such as the album’s intro, the aforementioned “Testify” and <a href="https://www.youtube.com/watch?v=shBAHpuOErs" target="_blank" rel="noopener">“One Time”</a> — which details the duo’s come-up using their own song titles, as well as their crew’s, as lyrical inspiration. About to celebrate the 25th birthday of their celebrated debut, Tek and General Steele give fans their best album since—one of maturity, evolution, and a deeper bond of brotherhood. &#8211; El Scribes
<p style="text-align: left;"><strong>Released</strong>: February 22, 2019<br />
<strong>Label</strong>: Bucktown USA Entertainment/Duck Down Music<br />
<strong>Guests</strong>: Raekwon, Rick Ross, Rapsody, Musiq SoulChild, GQ, Heather Victoria, SmittytheCAINSMITH<br />
<strong>Producers</strong>: The Soul Council (9th Wonder, Khrysis, Nottz, E. Jones, Eric G)
</p><p><strong>YBN Cordae &#8211; <em>The Lost Boy</em></strong>
</p><p><img class="size-full wp-image-97977 aligncenter" src="https://ambrosiaforheads.com/wp-content/uploads/2019/12/YBN-Cordae-Lost-Boy.jpg" alt="" width="500" height="500" srcset="https://ambrosiaforheads.com/wp-content/uploads/2019/12/YBN-Cordae-Lost-Boy.jpg 474w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/YBN-Cordae-Lost-Boy-150x150.jpg 150w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/YBN-Cordae-Lost-Boy-300x300.jpg 300w, https://ambrosiaforheads.com/wp-content/uploads/2019/12/YBN-Cordae-Lost-Boy-100x100.jpg 100w" sizes="(max-width: 500px) 100vw, 500px" />
</p><p>Like Lil Pump, Rich The Kid, JuiceWRLD, Lizzo, Nav and others, YBN Cordae is one of the relative newcomers who made a big splash on the 2019 charts. With his debut album, July&#8217;s <a href="https://open.spotify.com/album/6Pb7PMZtW0fuEM1lCGvCDu" target="_blank" rel="noopener"><em>The Lost Boy</em></a>, the North Carolina and Maryland-reared rapper cracked the Top 15 with the support of guest appearances from Pusha-T, Meek Mill, Anderson .Paak and Chance The Rapper, plus a J. Cole production credit. The 21-year-old&#8217;s breakout success showcased his lyricism and his singing abilities, but also the wise-beyond-his-years approach to family, love, loss, success, death, addiction and (as the album&#8217;s title suggests) self-examination. Counting Jedi Mind Tricks and Black Star as inspirations, Cordae opted to feature the work of Gil Scott-Heron, Donny Hathaway and Roberta Flack on his duet with Chance, <a href="https://ambrosiaforheads.com/2019/06/chance-the-rapper-ybn-cordae-rap-song-video/" target="_blank" rel="noopener">&#8220;Bad Idea,&#8221;</a> another example of the young talent&#8217;s appreciation for those who laid the foundation. While promoting the acclaimed album since the March release of lead video single <a href="https://www.youtube.com/watch?v=7lzE0kQnVIk" target="_blank" rel="noopener">&#8220;Have Mercy,&#8221;</a> Cordae amassed plenty of recognition as a freestyle rapper, too. While visiting Funkmaster Flex at HOT 97, he delivered <a href="https://ambrosiaforheads.com/2019/08/ybn-cordae-funkmaster-flex-freestyle-video/" target="_blank" rel="noopener">three exceptional verses</a> in which he touts reading <em>The Qur&#8217;an</em> at 12, toasts JAY-Z and admonishes rappers who rap for rapping&#8217;s sake. In October, he released one of 2019&#8217;s most memorable music videos, for his Paak-assisted <a href="https://ambrosiaforheads.com/2019/10/ybn-cordae-anderson-paak-rnp-video/" target="_blank" rel="noopener">&#8220;RNP (Rich N*gga Problems).&#8221;</a> Again, Cordae uses Black icons who came before him as inspiration, paying homage to <em>Shaft</em> and<em> Superfly</em>. Ultimately, what makes <em>The Lost Boy</em> one of the best albums of 2019 is not that a young MC made an album that older generations of Hip-Hop Heads can enjoy, but rather that he reminded us we&#8217;re never too old to rediscover ourselves. &#8211; Amanda Mester
<p style="text-align: left;"><strong>Released</strong>: July 26, 2019<br />
<strong>Label</strong>: Atlantic Records<br />
<strong>Guests</strong>: Chance The Rapper, Pusha-T, Anderson .Paak, Meek Mill, Ty Dolla $ign, Arin Ray<br />
<strong>Producers</strong>: self, Cardiak, J. Cole, Kid Culture, Bongo ByTheWay, Terrace Martin, illuid.haller, Flippa, Nils, CoopTheTruth, Smoko Ono, Take a Daytrip, CoopTheTruth, Russ Chell, Bazexx, Slim, G Koop, Maneesh, Rasool
</p><p><em>Ambrosia For Heads</em>&#8216; <a href="https://ambrosiaforheads.com/2018/12/best-rap-hiphop-albums-2018/" target="_blank" rel="noopener">Top Albums Of 2018</a>. <em>AFH</em>&#8216;s <a href="https://ambrosiaforheads.com/2017/12/best-rap-albums-year-2017/" target="_blank" rel="noopener">Top Albums Of</a> <a href="https://ambrosiaforheads.com/2017/12/best-rap-albums-year-2017/" target="_blank" rel="noopener">2017</a>.

<div class="fb-social-plugin fb-like" data-font="lucida grande" data-ref="below-post" data-href="https://ambrosiaforheads.com/2019/12/best-hiphop-albums-2019/" data-layout="button_count" data-share="true" data-width="450"></div>
</p>
	</div>
	
	<div class="article-facebook-like-box">
		<div class="fb-page" data-href="https://www.facebook.com/ambrosiaforheads/" data-small-header="true" data-adapt-container-width="true" data-hide-cover="true" data-show-facepile="false"><blockquote cite="https://www.facebook.com/ambrosiaforheads/" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/ambrosiaforheads/">Ambrosia For Heads</a></blockquote></div>
	</div>
	
			
		<script type="text/javascript" data-cookieconsent="necessary">
		jQuery(document).ready(function($){
			
			// Remove empty <p> tags
					
			$('.entry > p').each(function(i) {
			    var $this = $(this);
			    if($this.html().replace(/\s|&nbsp;/g, '').length == 0)
			        $this.remove();
			});
			
			$('.entry > p').each(function(i){
				
				var $this = $(this);
				
				if (i == 0) {
					
					//if (window.width < 768) {
						
						/*
						$(this).after('<div class="brid-in-content" style="margin:1.5em auto;"><div id="Brid_30311149" class="brid" itemprop="video" itemscope itemtype="http://schema.org/VideoObject"></div></div>');
						
						var script = document.createElement('script');
						script.type = 'text/javascript';
						script.async = true;
						script.src = '//services.brid.tv/player/build/brid.outstream.min.js';
						document.getElementsByTagName('head')[0].appendChild(script);
						
						setTimeout(function(){
							$bos("Brid_30311149", {"id":"3327","width":"550","height":"310"});
						}, 3000);
						*/
						
						
						
						
						/* removed 10/30
						$this.append('<div itemscope itemtype="https://schema.org/VideoObject" class="jwplayer-content"><meta itemprop="uploadDate" content="Thu May 23 2019 17:51:16 GMT-0700 (Pacific Daylight Time)"/><meta itemprop="name" content="Afh Trailer"/><meta itemprop="duration" content="PT1M2.253S" /><div id="botr_EHizUddg_ZyZ2sYoo_div"></div></div>');
						
						var script = document.createElement('script');
						script.type = 'text/javascript';
						script.src = 'https://cdn.jwplayer.com/players/EHizUddg-ZyZ2sYoo.js';
						document.getElementsByTagName('head')[0].appendChild(script);
						*/
						
						
					//}
					//else {
						
						
						$this.append('<div itemscope itemtype="https://schema.org/VideoObject" class="jwplayer-content"><meta itemprop="uploadDate" content="Thu May 23 2019 17:51:16 GMT-0700 (Pacific Daylight Time)"/><meta itemprop="name" content="Afh Trailer"/><meta itemprop="duration" content="PT1M2.253S" /><div id="botr_EHizUddg_xNj0BaMv_div"></div></div>');
						
						var script = document.createElement('script');
						script.type = 'text/javascript';
						script.src = 'https://cdn.jwplayer.com/players/EHizUddg-xNj0BaMv.js';
						document.getElementsByTagName('head')[0].appendChild(script);
						
						
						//temporary - Brid
						/*
						$(this).after('<div class="brid-in-content" style="margin:1.5em auto;"><div id="Brid_30311149" class="brid" itemprop="video" itemscope itemtype="http://schema.org/VideoObject"></div></div>');
						
						var script = document.createElement('script');
						script.type = 'text/javascript';
						script.async = true;
						script.src = '//services.brid.tv/player/build/brid.outstream.min.js';
						document.getElementsByTagName('head')[0].appendChild(script);
						
						setTimeout(function(){
							$bos("Brid_30311149", {"id":"3327","width":"550","height":"310"});
						}, 3000);
						*/
						
						/*
						
						$(this).after('<div style="position: relative; display: block; max-width: 640px;margin:1em 0;"><div style="padding-top: 56.25%;"><iframe style="position: absolute; top: 0px; right: 0px; bottom: 0px; left: 0px; width: 100%; height: 100%;" src="https://players.brightcove.net/6033281496001/4ARlTEZhs_default/index.html?videoId=6047622681001" allowfullscreen="allowfullscreen"></iframe></div></div>');
						*/
						
						/*
						$(this).after('<div class="brid-in-content" style="margin:1.5em auto;"><div id="Brid_62006226" class="brid" style="margin:0 auto;"></div></div>');
						
						var script = document.createElement('script');
						script.type = 'text/javascript';
						script.async = true;
						script.src = '//services.brid.tv/player/build/brid.min.js';
						document.getElementsByTagName('head')[0].appendChild(script);
						
						setTimeout(function(){
							$bp("Brid_62006226", {"id":"9708","width":"460","height":"280","video":"104421"});
						}, 3000);
						*/
						
					//}
				}
				else if (i == 4) {
					
					if (window.width > 767) {
					
						/*
						$(this).after('<div style="position: relative; display: block; max-width: 640px;margin:1em 0;"><div style="padding-top: 56.25%;"><iframe style="position: absolute; top: 0px; right: 0px; bottom: 0px; left: 0px; width: 100%; height: 100%;" src="https://players.brightcove.net/6033281496001/4ARlTEZhs_default/index.html?videoId=6047622681001" allowfullscreen="allowfullscreen"></iframe></div></div>');
						*/
						
					}
					
				}
			});
			
		});
		</script>
	
	
	<div class="pps-slider-nav"></div>	</div>

				<div class="post-widgets visible-lg visible-md">

					<ul class="sidebar">

						
					</ul>

				</div>

				<div class="single-mobile-ad visible-xs visible-sm">
                                    </div>
				
				<div class="hidden-xs">
<!-- 3lift marketing - Daniel 20190407 -->
                	<script type="text/plain" data-cookieconsent="marketing" src="https://ib.3lift.com/ttj?inv_code=ambrosiaforheads_article_sub"></script>
				</div>

				
																	

			
			<div class="row article-ad-block">
                <div class="col-md-12">
                    <div class="lower-banner visible-md visible-lg">
                        <!-- /33196227/AFH_Article_Instream_Leaderboard
<div id='div-gpt-ad-1477791585092-0' style='height:90px; width:728px;margin-left: auto;margin-right: auto;'>
<script>
window.width = window.innerWidth || document.documentElement.clientWidth || document.body.clientWidth;

if (window.width > 767) { 
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1477791585092-0'); });
}
</script>
</div>
-->

<!-- /284704979/ambrosiaforheads/AFH_Below_Article_Leaderboard DESKTOP -->
<div id='div-gpt-ad-1540251912042-3-desktop' style='height:90px; width:728px;'>
<script>
window.width = window.innerWidth || document.documentElement.clientWidth || document.body.clientWidth;

if (window.width > 767) { 
googletag.cmd.push(function() { 

/* SORTABLE */					deployads.push(function() { deployads.gpt.display("div-gpt-ad-1540251912042-3-desktop"); });

/* googletag.display('div-gpt-ad-1540251912042-3-desktop'); }); */
});
}
</script>
</div>                    </div>
                </div>
            </div>
            
			            	
            	<div class="below-content-posts">
	            	
	            	<h2>Most Recent Stories</h2>
            	
	            								
							<div class="below-content-post">
								
								<a href="https://ambrosiaforheads.com/2019/12/benny-the-butcher-griselda-documentary-video/" target="_blank">
									
									<div class="below-content-img" style="background-image:url(https://ambrosiaforheads.com/wp-content/uploads/2019/12/Benny-The-Butcher-12-19.png)"></div>
									<div class="below-content-title">
										Benny Is Far From An Overnight Success. Look Back At The Grind Of A Top MC (Video)									</div>
								
								</a>
								
							</div>
							
														
							<div class="below-content-post">
								
								<a href="https://ambrosiaforheads.com/2019/12/tekashi-6ix9ine-sentence-release/" target="_blank">
									
									<div class="below-content-img" style="background-image:url(https://ambrosiaforheads.com/wp-content/uploads/2019/02/Tekahashi-2-19.jpg)"></div>
									<div class="below-content-title">
										Tekashi 6ix9ine Is Expected To Be Released From Prison In 2020									</div>
								
								</a>
								
							</div>
							
														
							<div class="below-content-post">
								
								<a href="https://ambrosiaforheads.com/2019/12/a-new-mos-def-al-green-mashup-brings-much-love-happiness-audio/" target="_blank">
									
									<div class="below-content-img" style="background-image:url(https://ambrosiaforheads.com/wp-content/uploads/2019/12/Mos-Def-Al-Green.png)"></div>
									<div class="below-content-title">
										A New Mos Def &#038; Al Green Mashup Brings Much Love &#038; Happiness (Audio)									</div>
								
								</a>
								
							</div>
							
														
							<div class="below-content-post">
								
								<a href="https://ambrosiaforheads.com/2019/12/andre-3000-rick-rubin-interview-audio/" target="_blank">
									
									<div class="below-content-img" style="background-image:url(https://ambrosiaforheads.com/wp-content/uploads/2019/12/Andre-3000-12-19.jpg)"></div>
									<div class="below-content-title">
										Andre 3000 Speaks On Not Having The Confidence To Make New Music (Audio)									</div>
								
								</a>
								
							</div>
							
														
							<div class="below-content-post">
								
								<a href="https://ambrosiaforheads.com/2019/12/nipsey-hussle-bodyguard-wack-100-video/" target="_blank">
									
									<div class="below-content-img" style="background-image:url(https://ambrosiaforheads.com/wp-content/uploads/2019/12/Screen-Shot-2019-12-17-at-12.17.31-PM.png)"></div>
									<div class="below-content-title">
										J Roc Punches Wack 100 In Defense Of Nipsey Hussle&#8217;s Legacy (Video)									</div>
								
								</a>
								
							</div>
							
														
							<div class="below-content-post">
								
								<a href="https://ambrosiaforheads.com/2019/12/wu-tang-clan-popa-poppa-obituary/" target="_blank">
									
									<div class="below-content-img" style="background-image:url(https://ambrosiaforheads.com/wp-content/uploads/2019/12/Cappadonna-Masta-Killa-Poppa-Wu.jpg)"></div>
									<div class="below-content-title">
										Wu-Tang Clan Spiritual Leader Popa Wu Has Passed Away									</div>
								
								</a>
								
							</div>
							
							            
            	</div>
            
            			
		</div>

		<div class="col-md-4 sidebar-content pull-left visible-lg visible-md">
            <div>
                <div class="top-sidebar-content">
                    <div class="bg-gray facebook-box">
                        <div class="fb-like-box" data-href="https://www.facebook.com/ambrosiaforheads" data-colorscheme="light" data-show-faces="false" data-header="false" data-stream="false" data-show-border="false"></div>
                    </div>
                    <div class="bg-gray youtube-box">
                        <a href="https://www.youtube.com/aforhtv" target="_blank"><img src="https://ambrosiaforheads.com/wp-content/themes/ambrosiaforheads_v2/images/sm-youtube-sidebar.png" alt="AFH on YouTube"></a>
                    </div>
                    <div class="bg-gray twitter-box">
                        <a href="https://twitter.com/ambrosia4heads" class="twitter-follow-button" data-show-count="false">Follow @ambrosia4heads</a>
<!-- twitter widget Marketing - Daniel 20190407 -->
                        <script type="text/plain" data-cookieconsent="marketing">!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
                    </div>
                </div>

                <ul class="sidebar">
		
		            <li id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><!-- /33196227/AFH_Article_LR1
<div id="div-gpt-ad-1477860397051-0" class="sidebar-refresh-ad" style="height: 250px; width: 300px; margin: auto;"><script>
	jQuery(document).ready(function($){
		
		window.width = window.innerWidth || document.documentElement.clientWidth || document.body.clientWidth;
		
		if (window.width > 767) {
			googletag.cmd.push(function() { googletag.display('div-gpt-ad-1477860397051-0'); });
		}
		else {
			$('#div-gpt-ad-1477860397051-0').detach().appendTo('.single-mobile-ad');
		setTimeout(function(){
			googletag.cmd.push(function() { 
				googletag.display('div-gpt-ad-1477860397051-0');

			});
		}, 1000)
		}
		
	});

</script>
-->

<!-- /284704979/ambrosiaforheads/AFH_Above_Box DESKTOP -->
<div id='div-gpt-ad-1540251912042-1-desktop' style='min-height:250px; width:300px;'>
<script>
window.width = window.innerWidth || document.documentElement.clientWidth || document.body.clientWidth;
if (window.width > 767) {
	googletag.cmd.push(function() { 
		
		/* SORTABLE */
deployads.push(function() { deployads.gpt.display("div-gpt-ad-1540251912042-1-desktop"); });
		
	/*	googletag.display('div-gpt-ad-1540251912042-1-desktop'); }); */
});
	}
										 
</script>
</div></div></li>
<li id="afh_living_legends_widget-16" class="widget widget_afh_living_legends_widget"><h2 class="widgettitle">AFH On Spotify</h2>
<div class="living-legends custom-widget-content">
	<div class="header-data">
		<iframe src="https://embed.spotify.com/?uri=spotify%3Auser%3Aambrosiaforheads%3Aplaylist%3A1Ssx21OFFRNJMMvlG2xeWV" width="300" height="380" frameborder="0" allowtransparency="true"></iframe>	</div>
	</div>
</li>
<li id="custom_html-4" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><!-- /33196227/AFH_Article_LR2

<div id='div-gpt-ad-1477791617272-0' style='height:250px; width:300px; margin: auto;'>
<script>
jQuery(document).ready(function($){
	window.width = window.innerWidth || document.documentElement.clientWidth || document.body.clientWidth;
	
	if (window.width > 767) {
		googletag.cmd.push(function() { 
			
			googletag.display('div-gpt-ad-1477791617272-0');

		});	
	}
});
</script>


--></div></li>

                </ul>
            </div>
            <div class="hidden-xs hidden-sm sticky-sidebar">
				            </div>
            
        </div>
        
	</div>

</div>
<div class="mobile-sticky-wrapper visible-xs">
    <!-- /33196227/AFH_Mobile_ROS_Leaderboard
<div id='div-gpt-ad-1477792058192-0' style='height:50px; width:320px;margin-left: auto;margin-right: auto;' class="mobile-refresh-ad">
<script>
window.width = window.innerWidth || document.documentElement.clientWidth || document.body.clientWidth;

if (window.width < 768) { 
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1477792058192-0'); });
}
</script>
</div>
-->

<!-- /284704979/ambrosiaforheads/AFH_Above_Article_Leaderboard_Flex MOBILE -->
<div id='div-gpt-ad-1540251912042-0-mobile'>
<script>
window.width = window.innerWidth || document.documentElement.clientWidth || document.body.clientWidth;
if (window.width < 768) {
googletag.cmd.push(function() { 

/* SORTABLE */					deployads.push(function() { deployads.gpt.display("div-gpt-ad-1540251912042-0-mobile"); });

/* googletag.display('div-gpt-ad-1540251912042-0-mobile'); }); */
});
}
</script>
</div></div>

<footer class="footer hidden-sm hidden-xs">
    <div class="row">
    	<div class="col-md-9">
    		<div class="footer-logo">
    			<a href="https://ambrosiaforheads.com">
                    AFH
                </a>
    		</div>
    		<nav class="footer-nav navigation visible-md visible-lg">
                <ul id="menu-main-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14576"><a title="Fresh" href="https://ambrosiaforheads.com/category/fresh/">Fresh</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14570"><a title="Old School" href="https://ambrosiaforheads.com/category/fresh/old-school-8/">Throwback</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14571"><a title="Audio" href="https://ambrosiaforheads.com/category/fresh/audio/">Audio</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14572"><a title="Video" href="https://ambrosiaforheads.com/category/fresh/video/">Video</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-92718"><a href="http://afhtv.com">AFH TV</a></li>
</ul>    		</nav>

    		<!-- Mobile navigation -->
            <nav class="footer-nav navigation visible-sm visible-xs">
                <select class="menu"><option value="" selected="selected">&rArr; Navigate</option><option  value="https://ambrosiaforheads.com/category/fresh/">Fresh</option>
<option  value="https://ambrosiaforheads.com/category/fresh/old-school-8/">Throwback</option>
<option  value="https://ambrosiaforheads.com/category/fresh/audio/">Audio</option>
<option  value="https://ambrosiaforheads.com/category/fresh/video/">Video</option>
<option  value="http://afhtv.com">AFH TV</option>
</select>            </nav>
    	</div>
    </div>
    <div class="row credits">
    	<div class="col-md-6 copyright">
    		Copyright &copy; 2019 All Rights Reserved
    	</div>
    </div>
</footer>

<script type='text/javascript' src='https://ambrosiaforheads.com/wp-includes/js/jquery/jquery.form.min.js?ver=4.2.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/ambrosiaforheads.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://ambrosiaforheads.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.0.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pps_options_object = {"scroll_up":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://ambrosiaforheads.com/wp-content/plugins/paged-post-slider/paged-post.js?ver=4.9.13'></script>
<script type='text/javascript' src='https://ambrosiaforheads.com/wp-content/themes/ambrosiaforheads_v2/js/bootstrap.min.js?ver=1.0'></script>
<script type='text/javascript' src='https://ambrosiaforheads.com/wp-content/themes/ambrosiaforheads_v2/js/jquery.bxslider.min.js?ver=4.1.1'></script>
<script type='text/javascript' src='https://ambrosiaforheads.com/wp-content/themes/ambrosiaforheads_v2/js/slick.min.js?ver=1.3.15'></script>
<script type='text/javascript' src='https://ambrosiaforheads.com/wp-content/themes/ambrosiaforheads_v2/js/jquery.waypoints.min.js?ver=3.1.1'></script>
<script type='text/javascript' src='https://ambrosiaforheads.com/wp-content/themes/ambrosiaforheads_v2/js/jquery.history.js?ver=1.8'></script>
<script type='text/javascript' src='https://ambrosiaforheads.com/wp-content/themes/ambrosiaforheads_v2/js/js.cookie.js?ver=2.0'></script>
<script type='text/javascript' src='https://ambrosiaforheads.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var afhAJAX = {"ajaxurl":"https:\/\/ambrosiaforheads.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://ambrosiaforheads.com/wp-content/themes/ambrosiaforheads_v2/js/behavior.js?ver=1.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var FB_WP=FB_WP||{};FB_WP.queue={_methods:[],flushed:false,add:function(fn){FB_WP.queue.flushed?fn():FB_WP.queue._methods.push(fn)},flush:function(){for(var fn;fn=FB_WP.queue._methods.shift();){fn()}FB_WP.queue.flushed=true}};window.fbAsyncInit=function(){FB.init({"xfbml":true,"appId":"149229425165568"});if(FB_WP && FB_WP.queue && FB_WP.queue.flush){FB_WP.queue.flush()}}
/* ]]> */
</script>
<script type="text/javascript">(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id)){return}js=d.createElement(s);js.id=id;js.src="https:\/\/connect.facebook.net\/en_US\/all.js";fjs.parentNode.insertBefore(js,fjs)}(document,"script","facebook-jssdk"));</script>
<script type='text/javascript' src='https://ambrosiaforheads.com/wp-includes/js/wp-embed.min.js?ver=4.9.13'></script>
<div id="fb-root"></div><script type="text/plain" data-cookieconsent="marketing">
  var _sf_async_config={};
  /** CONFIGURATION START **/
  _sf_async_config.uid = 55767;
  _sf_async_config.domain = "ambrosiaforheads.com";
  /** CONFIGURATION END **/
  (function(){
    function loadChartbeat() {
      window._sf_endpt=(new Date()).getTime();
      var e = document.createElement("script");
      e.setAttribute("language", "javascript");
      e.setAttribute("type", "text/javascript");
      e.setAttribute('src', '//static.chartbeat.com/js/chartbeat_video.js');
      document.body.appendChild(e);
    }
    var oldonload = window.onload;
    window.onload = (typeof window.onload != "function") ?
      loadChartbeat : function() { oldonload(); loadChartbeat(); };
  })();
</script>
  
</body>
<!-- Youtube iFrame NECESSARY - Daniel 04072019 -->
<script data-cookieconsent="necessary">
  (function(){
    if(!window.postMessage){ return; }

    //LoadYouTube's iframeAPI
    var tag=document.createElement('script');
    tag.src="https://www.youtube.com/iframe_api";
    var firstScriptTag=document.getElementsByTagName('script')[0];
    firstScriptTag.parentNode.insertBefore(tag, firstScriptTag);

    //Tell Chartbeat to autodetect the YouTube iframes
    var _cbv=window._cbv||(window._cbv=[]);
    _cbv.push(['autoDetectYouTubeIframes']);
  }());

</script>

</html>